Neutron uses wrong os-auth-url

asked 2015-08-19 16:58:55 -0500

Black-Pixel gravatar image

updated 2015-08-19 17:02:22 -0500

I have Keystone (Juno) configured to listen on port 35358. I'm using HAProxy for SSL termination, it's listening on 35357 and forwarding to 35358. However the command line tool neutron refuses to use the correct os-auth-url even if I supply it directly.

Here is an example:

neutron --os-auth-url https://ControllerNode.sdn:35357/v2.0 net-list
Unable to establish connection to http://ControllerNode.sdn:35357/v2.0/tokens

This problem only occurs when I try to use the ssl url. The following does work:

neutron --os-auth-url http://ControllerNode.sdn:35358/v2.0 net-list

Is this a bug or did I miss something?

Keystone and nova work, it's only neutron that has this problem.

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2015-08-20 03:34:51 -0500

updated 2015-08-20 03:36:15 -0500

Did you also try the environment variable to supply the value ?

export OS_AUTH_URL=http://ControllerNode.sdn:35358/v2.0

If that is working whereas the CLI param does not, I think that is a bug...

edit flag offensive delete link more

Comments

The same happens with exports. This works:

export OS_AUTH_URL=http://ControllerNode.sdn:35358/v2.0

This doesn't work:

export OS_AUTH_URL=https://ControllerNode.sdn:35357/v2.0
neutron net-list
Unable to establish connection to http://ControllerNode.sdn:35357/v2.0/tokens
Black-Pixel gravatar imageBlack-Pixel ( 2015-08-20 05:23:25 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-19 16:58:55 -0500

Seen: 233 times

Last updated: Aug 20 '15