Ask Your Question
0

Error deploying VMs in Havana "Timeout while waiting on RPC response" without Neutron,using 13.10

asked 2013-12-03 10:19:39 -0500

sib gravatar image

updated 2014-01-22 15:12:48 -0500

Evgeny gravatar image

Hello, I have a ubuntu 13.10 vm running(controller) and a second ubuntu 13.10(compute1) vm for nova-compute. I have followed all the instructions from the wiki, http://docs.openstack.org/havana/install-guide/install/apt/content/ch_preface.html .

After creating an instance, I get error state.

If I nova show id, in the fault section I get: u'Timeout while waiting on RPC response

My topology is based on the wiki, using nova-network(installed on controller + compute1).

Where should I start looking for problems?

It is worth mentioning that my controller can ping 8.8.8.8 successfully, but has a hard time with dns(something to do with my vm's settings). But probably this has nothing to do with the internal vm's instance error. I have checked the various nova logs, and I have a few errors(with rabbitmq port) but they fix themselves after a few seconds/minutes.

Also to the rabbitmq logs are all clean...

My nova --debug show ID file: http://pastebin.com/KxMwm02S

My nova network log: http://pastebin.com/qgKkUjY3 (for controller)

My nova api-paste.ini file for controller: http://pastebin.com/b2PD3Tzm


   sudo nova-manage service list
Binary           Host                                 Zone             Status     State Updated_At
nova-cert        ucloud                               internal         enabled    :-)   2013-12-03 16:12:10
nova-consoleauth ucloud                               internal         enabled    :-)   2013-12-03 16:12:10
nova-scheduler   ucloud                               internal         enabled    :-)   2013-12-03 16:12:10
nova-conductor   ucloud                               internal         enabled    :-)   2013-12-03 16:12:10
nova-network     compute1                             internal         enabled    :-)   2013-12-03 16:12:06
nova-compute     compute1                             nova             enabled    :-)   2013-12-03 16:12:10
nova-network     ucloud                               internal         enabled    :-)   2013-12-03 16:12:04

My nova.conf file for controller


[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
iscsi_helper=tgtadm
libvirt_use_virtio_for_bridges=True
connection_type=libvirt
root_helper=sudo nova-rootwrap /etc/nova/rootwrap.conf
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
volumes_path=/var/lib/nova/volumes
enabled_apis=ec2,osapi_compute,metadata
rpc_backend = nova.rpc.impl_kombu
rabbit_host = ucloud
rabbit_password = di
my_ip=192.168.200.2
vncserver_listen=192.168.200.2
vncserver_proxyclient_address=192.168.200.2
auth_strategy=keystone

network_manager=nova.network.manager.FlatDHCPManager
firewall_driver=nova.virt.libvirt.firewall.IptablesFirewallDriver
network_size=254
allow_same_net_traffic=False
multi_host=True
send_arp_for_ha=True
share_dhcp_address=True
force_dhcp_release=True
flat_network_bridge=br100
flat_interface=eth0
public_interface=eth0
#rabbit_host=controller


[database]
# The SQLAlchemy connection string used to connect to the database
connection = mysql://nova:di@ucloud/nova

[keystone_authtoken]
auth_host = ucloud
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = nova
admin_password = di

My nova conf file for compute1 node: http://pastebin.com/eivjJS56

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-12-03 11:00:35 -0500

dheeru gravatar image
1. Is the passsword for sql and keystone admin password is same ? 
2. Can you look at /var/log/nova/api.log and other logs for more details ?
3. Are you able run 'keystone togken-get', 'keystone user-list' etc command from command line ?
4. Are you able to run the glance commands ?
5. Can you check whether all the services are up and running ?
edit flag offensive delete link more

Comments

1)password is the same for everything, for testing purposes 2)I checked the /var/log/nova-api.log and other logs in that folder but found no persistent errors. 3)4)I can run all keystone/glance commands 5)How would i do this? I have run sudo nova-manage service list(mentioned above).

sib gravatar imagesib ( 2013-12-03 11:07:20 -0500 )edit

can you send me the nova.conf and api-paste.conf as well ?

dheeru gravatar imagedheeru ( 2013-12-03 11:50:47 -0500 )edit

nova/api-paste.ini: http://pastebin.com/b2PD3Tzm nova.conf for controller is above, nova.conf for compute1 node: http://pastebin.com/eivjJS56

sib gravatar imagesib ( 2013-12-03 12:11:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-03 10:19:39 -0500

Seen: 1,163 times

Last updated: Dec 03 '13