swiftonfile restart trouble

asked 2015-08-19 02:10:48 -0500

jeanlondon gravatar image

Hi I followed all steps on SAIO procedure using loopback device setup and everything went ok.

I have to problems:

  1. Where do I have to set the ip address of my server in order to access via web browser instead of localhost:8080 that doesn't work
    1. After install swiftonfile and follow all steps and adding/replacing Storage-Policy 2 to make iqual to turorial, I typed to startmain I got this error

Traceback (most recent call last): File "/usr/local/bin/swift-object-server", line 10, in <module> execfile(__file__) File "/home/swift/swift/bin/swift-object-server", line 27, in <module> **options)) File "/home/swift/swift/swift/common/wsgi.py", line 878, in run_wsgi error_msg = strategy.bind_ports() File "/home/swift/swift/swift/common/wsgi.py", line 485, in bind_ports drop_privileges(self.conf.get('user', 'swift')) File "/home/swift/swift/swift/common/utils.py", line 1603, in drop_privileges user = pwd.getpwnam(user) KeyError: 'getpwnam(): name not found: <your-user-name>'

Please help what I'm doing wrong.

edit retag flag offensive close merge delete

Comments

Hi, Did you find a solution to your problem ? I have the same one. Thank you,

Ghada gravatar imageGhada ( 2016-06-20 22:15:51 -0500 )edit