All compute nodes state appear as down

asked 2015-08-18 18:44:29 -0600

Tabi T gravatar image

I installed OpenStack Juno and spawn some instances successfully. After a failed attempt to delete a volume, I noticed one compute node state changed to down. Shortly after that all the other compute nodes states and change to down. I have reboot all controllers, compute and storage node and state of the compute nodes still appear as down.

I am running Ceph OSD for storage.

Any what could be the cause and how to resolve it?

Tabi

edit retag flag offensive close merge delete

Comments

can you post the nova logs from compute nodes and controller node?

natsu gravatar imagenatsu ( 2015-08-18 19:04:55 -0600 )edit

Hi, Nova-api.log or nova-all.log?

Tabi T gravatar imageTabi T ( 2015-08-19 01:44:05 -0600 )edit

Here is nova-all log excerpt from the compute node/..

182>Aug 18 22:30:04 node-10 nova-compute Skipping periodic task _periodic_update_dns because its interval is negative <182>Aug 18 22:30:04 node-10 nova-compute Loading compute driver 'libvirt.LibvirtDriver' <182>Aug 18 22:30:04 node-10 nova-comp

Tabi T gravatar imageTabi T ( 2015-08-19 02:41:19 -0600 )edit

Checked Nova log on Controller node and nothing serious/...

182>Aug 19 08:41:09 node-2 nova-api 10.12.1.2 "GET /v2/3809c40125364255be74aea103e3347e/servers/detail?all_tenants=True&host=node-7.tabi.co HTTP/1.1" status: 200 len: 206 time: 0.0$ <182>Aug 19 08:41:10 node-2 nova-api 0.152s 10.12.1.4 OP

Tabi T gravatar imageTabi T ( 2015-08-19 03:48:54 -0600 )edit

yeah, nothing weird on logs..... is the Compute Node machine memory still OK?

natsu gravatar imagenatsu ( 2015-08-19 21:46:39 -0600 )edit