KILO: external-router interfaces in DOWN state. Can't ping external interface from the host in external network.

asked 2015-08-18 16:54:44 -0500

danial gravatar image


I have a 3 node setup KILO OPENSTACK environment in Ubuntu 14.04.3 LTS.

The issue I am having is that I can't ping external-gateway interface IP from the Host connected to this External Network. Also all the external-router interfaces are in DOWN state.


Here is the snippet of topology diagram to give idea on the setup.

[Host][External Router in OPENSTACK-NETURON]

On Network Node, eth2 is used for EXTERNAL NETWORK.

tcpdump shows that the packets are received on correct ethernet eht2 and bridge br-ex.

root@network:~# tcpdump -i br-ex tcpdump: WARNING: br-ex: no IPv4 address assigned tcpdump: verbose output suppressed, use -v or -vv for full protocol decode listening on br-ex, link-type EN10MB (Ethernet), capture size 65535 bytes 14:44:48.660782 ARP, Request who-has tell, length 46

br-ex state is also UP. Not sure why the packets are not being sent to interface on this External Router with IP ? Also the interface state is also DOWN. This looks like the cause the of the issue.


root@controller:~# neutron port-show 01b3d75a-710c-4a1e-89e7-fd1bc26bd3a0 +-----------------------+--------------------------------------------------------------------------------------+ | Field | Value | +-----------------------+--------------------------------------------------------------------------------------+ | admin_state_up | True | | allowed_address_pairs | | | binding:host_id | network | | binding:profile | {} | | binding:vif_details | {"port_filter": true, "ovs_hybrid_plug": true} | | binding:vif_type | ovs | | binding:vnic_type | normal | | device_id | 6409dbca-d840-43c1-9465-8225af72c9ad | | device_owner | network:router_gateway | | extra_dhcp_opts | | | fixed_ips | {"subnet_id": "ce344edd-7adf-4cf9-b550-35c51b4a6ddd", "ip_address": ""} | | id | 01b3d75a-710c-4a1e-89e7-fd1bc26bd3a0 | | mac_address | fa:16:3e:25:99:fa | | name | | | network_id | d1c0651e-4b70-44fc-91eb-3921cc1bf17e | | security_groups | | | status | DOWN | | tenant_id | | +-----------------------+--------------------------------------------------------------------------------------+

root@controller:~# neutron router-port-list demo-router +--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+ | id | name | mac_address | fixed_ips | +--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+ | 01b3d75a-710c-4a1e-89e7-fd1bc26bd3a0 | | fa:16:3e:25:99:fa | {"subnet_id": "ce344edd-7adf-4cf9-b550-35c51b4a6ddd", "ip_address": ""} | | ff0414a6-b236-4073-894f-7459e9b64214 | | fa:16:3e:1b:cb:b7 | {"subnet_id": "bd6c29df-83f3-4db1-adc7-9abb06f9e04f", "ip_address": ""} | +--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+

edit retag flag offensive close merge delete


I came across the STATE UNKNOWN and noqueue.

Can someone please look into it and help on how to fix the below.

root@network:~# ip link show dev br-ex 6: br-ex: <broadcast,up,lower_up> mtu 1500 qdisc noqueue state UNKNOWN mode DEFAULT group default link/ether 00:0c:29:e1:04:53 brd ff:ff:ff:ff:f

danial gravatar imagedanial ( 2015-08-18 19:18:03 -0500 )edit

Issue this command in neutron server and see the output "ovs-vsctl show" if br-ex is mapped to any physical network also ping your gateway from any machine in your network and see if it is reachable. I think you have setup a wrong gateway with subnet.

soumitrakarmakar gravatar imagesoumitrakarmakar ( 2015-08-19 00:21:27 -0500 )edit

Posting my reply in answer section due to lack of space in comment box :-)

danial gravatar imagedanial ( 2015-08-19 12:50:15 -0500 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2015-08-19 12:49:36 -0500

danial gravatar image

updated 2015-08-19 13:16:47 -0500

enter code hereHi soumitrakarmakar,

Thanks for looking into this.

The correct physical NIC is tied to the bridge. Please see the ovs-vsctl show output. eth2 is tied to br-ex.

Also, I am pinging EXTERNAL-ROUTER interface from host in same subnet so gateway will not come into picture. You can see in the tcpdump output posted above where I can see the ARP request being received on correct bridge br-ex But looks like they are not being forwarded to ext-interface of ROUTER in openstack.


root@network:~# ovs-vsctl show


Bridge br-tun
    Port br-tun
        Interface br-tun
            type: internal
    Port patch-int
        Interface patch-int
            type: patch
            options: {peer=patch-tun}
    Port "gre-0a00011f"
        Interface "gre-0a00011f"
            type: gre
            options: {in_key=flow, local_ip="", out_key=flow, remote_ip=""}
Bridge br-int
    fail_mode: secure
    Port "tap96af0cc7-80"
        tag: 1
        Interface "tap96af0cc7-80"
            type: internal
    Port int-br-ex
        Interface int-br-ex
    Port patch-tun
        Interface patch-tun
            type: patch
            options: {peer=patch-int}
    Port br-int
        Interface br-int
            type: internal
Bridge br-ex
    Port br-ex
        Interface br-ex
            type: internal
    Port "eth2"
        Interface "eth2"
    Port phy-br-ex
        Interface phy-br-ex
ovs_version: "2.0.2"


edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2015-08-18 16:54:44 -0500

Seen: 2,607 times

Last updated: Aug 19 '15