Ask Your Question
1

Compute Node Error - ValueError: failed to detect a valid IP address from u'MANAGEMENT_INTERFACE_IP_ADDRESS'

asked 2015-08-18 04:58:20 -0500

ThaoNM gravatar image

Dear all,

I config compute node with hypervior is VMWARE. When i start openstack-nova-compute, in log file show:
2015-08-18 16:31:59.725 12957 TRACE nova.openstack.common.threadgroup ValueError: failed to detect a valid IP address from u'MANAGEMENT_INTERFACE_IP_ADDRESS'
2015-08-18 16:31:59.725 12957 TRACE nova.openstack.common.threadgroup
2015-08-18 16:31:59.725 12957 TRACE nova.openstack.common.threadgroup
2015-08-18 16:31:59.727 12957 INFO oslo_vmware.api [req-b25f656a-1ebc-4d1c-8b50-3d5af06acb91 - - - - -] Logging out and terminating the current session with ID = ea19c.
/usr/lib/python2.7/site-packages/requests/packages/urllib3/connectionpool.py:768: InsecureRequestWarning: Unverified HTTPS request is being made. Adding certificate verification is strongly advised. See: https://urllib3.readthedocs.org/en/latest/security.html (https://urllib3.readthedocs.org/en/la...) InsecureRequestWarning)

nova.conf:

[DEFAULT]

rpc_backend = rabbit
auth_strategy = keystone
my_ip = 10.10.0.30
vnc_enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = 10.10.0.30
novncproxy_base_url = http://controller:6080/vnc_auto.html
verbose = True
compute_driver=vmwareapi.VMwareVCDriver

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-11-03 08:02:48 -0500

updated 2015-11-04 07:43:10 -0500

I think you changed 'my_ip' to '10.10.0.30' after having it copy-pasted from the install guide as 'MANAGEMENT_INTERFACE_IP_ADDRESS' and tried to use it whit that value.

So that wrong "hostname" got saved in the DB when it should have been a numerical IP@...

You can fix it by doing the following on the controller node:

# mysql -u root -p MY_PASSWORD
use nova;
select * from compute_nodes where host_ip = 'MANAGEMENT_INTERFACE_IP_ADDRESS';

As explained in the installation documentation, host_ip must always be specified in dotted numerical notation, string host names are not allowed...

DAMHIKT

Check that is indeed the problem with the preceding "SELECT" SQL command, then delete the offending rows from your DB, with this one:

# mysql -u root -p MY_PASSWORD
use nova;
delete from compute_nodes where host_ip = 'MANAGEMENT_INTERFACE_IP_ADDRESS';

and restart nova service on the compute node so that it re-register itself properly in the DB...

systemctl start openstack-nova-compute.service

That should do it, be extra careful if your cloud is in production mode, though...

The same solution works in case you tried to use a properly resolving hostname as 'my_ip', thinking that it should work... Just adapt the SQL command to search / delete rows containing your hostname instead of 'MANAGEMENT_INTERFACE_IP_ADDRESS'...

If someone use that recipe to fix his problem, please mark this answer as the solution to this question, thanks...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-08-18 04:58:20 -0500

Seen: 1,653 times

Last updated: Nov 04 '15