Setting up openstack dev env - Permission denied error

asked 2015-08-16 20:02:02 -0500

prem gravatar image

updated 2015-08-16 20:10:57 -0500

Im trying to setup my local dev env for openstack but get the following error -

I checked the permissions and the devstack folder is owned by the current user.

015-08-17 00:57:11.435 | 3ec4314 Updated from generate-constraints
2015-08-17 00:57:11.436 | + cd /home/premlaks/devstack
2015-08-17 00:57:11.436 | + '[' '!' -d /opt/stack/requirements/.venv ']'
2015-08-17 00:57:11.436 | + PIP_VIRTUAL_ENV=/opt/stack/requirements/.venv
2015-08-17 00:57:11.436 | + pip_install -U pbr
2015-08-17 00:57:11.600 | + env http_proxy= https_proxy= no_proxy= PIP_FIND_LINKS=file:///opt/stack/.wheelhouse /opt/stack/requirements/.venv/bin/pip install -U pbr
2015-08-17 00:57:11.852 | The directory '/home/premlaks/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
2015-08-17 00:57:11.990 | The directory '/home/premlaks/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
2015-08-17 00:57:12.081 | /opt/stack/requirements/.venv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latest/security.html#insecureplatformwarning.
2015-08-17 00:57:12.081 |   InsecurePlatformWarning
2015-08-17 00:57:12.487 | Requirement already up-to-date: pbr in /opt/stack/requirements/.venv/lib/python2.7/site-packages
2015-08-17 00:57:12.567 | + local 'test_req=-U pbr/test-requirements.txt'
2015-08-17 00:57:12.567 | + [[ -e -U pbr/test-requirements.txt ]]
2015-08-17 00:57:12.567 | + PIP_VIRTUAL_ENV=/opt/stack/requirements/.venv
2015-08-17 00:57:12.568 | + pip_install /opt/stack/requirements
2015-08-17 00:57:13.214 | + env http_proxy= https_proxy= no_proxy= PIP_FIND_LINKS=file:///opt/stack/.wheelhouse /opt/stack/requirements/.venv/bin/pip install /opt/stack/requirements
2015-08-17 00:57:13.985 | The directory '/home/premlaks/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
2015-08-17 00:57:14.385 | The directory '/home/premlaks/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.


2015-08-17 00:57:14.388 | Processing /opt/stack/requirements
2015-08-17 00:57:15.251 | Collecting fixtures>=1.3.1 (from openstack.requirements==0.0.1.dev1831)
2015-08-17 00:57:15.339 | /opt/stack/requirements/.venv/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is ...
(more)
edit retag flag offensive close merge delete