Ask Your Question
0

force windows image to use EC2 metadata only for cloudbase-init

asked 2015-08-15 11:54:48 -0600

senyapsudah gravatar image

hi guys,

it seems like my windows image stuck on the first boot. it stuck at http service. is there anyway for us to force the image to look only for EC2 server instead of others.

thanks

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-08-15 12:52:12 -0600

alexpilotti gravatar image

In cloudbase-init.conf and cloudbase-init-unattend.conf you can change the metadata providers and their order. For example:

metadata_service=cloudbaseinit.metadata.services.ec2service.EC2Service
edit flag offensive delete link more
0

answered 2015-08-15 19:13:12 -0600

senyapsudah gravatar image

it seems the issue with my image is not because of the metadata service. mine is almost the same with this case.

https://ask.openstack.org/en/question/58913/windows-2012-vm-stuck-in-getting-ready/

What i need to do is to not attached any private keys to the instance creation. the windows server both 2008 or 2012 will boot normally.

is it possible to configure cloud-init not to accept any private keys by default for windows? as sometime user didn't care if private keys are attached to instance launch workflow. they just click "Next" only.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-15 11:54:48 -0600

Seen: 318 times

Last updated: Aug 15 '15