instance creations are failing in Kilo

asked 2015-08-14 04:47:29 -0600

Nithin T N gravatar image

updated 2015-08-14 12:48:22 -0600

rbowen gravatar image

I've setup Kilo environment with 1 controller, 2 compute ,1 neutron node and 1 storage node.

[root@~]# nova service-list
+----+------------------+-----------------+----------+---------+-------+----------------------------+-----------------+
| Id | Binary           | Host            | Zone     | Status  | State | Updated_at                 | Disabled Reason |
+----+------------------+-----------------+----------+---------+-------+----------------------------+-----------------+
| 1  | nova-conductor   | ameacldopctrl02 | internal | enabled | up    | 2015-08-14T19:22:03.000000 | -               |
| 2  | nova-consoleauth | ameacldopctrl02 | internal | enabled | up    | 2015-08-14T19:22:04.000000 | -               |
| 3  | nova-cert        | ameacldopctrl02 | internal | enabled | up    | 2015-08-14T19:22:04.000000 | -               |
| 4  | nova-compute     | ameacldcompt01  | nova     | enabled | up    | 2015-08-14T19:22:00.000000 | -               |
| 5  | nova-compute     | ameacldcompt02  | nova     | enabled | up    | 2015-08-14T19:22:00.000000 | -               |
+----+------------------+-----------------+----------+---------+-------+----------------------------+-----------------+
[root@~]#

My instance creation will run for 2 minutes and get into error state . Error message (Error: Failed to perform requested operation on instance "linux", the instance has an error status: Please try again later [Error: Unknown]. )

I'm tried of looking at the logs , can someone advice what could be the possible cause, please let me know if any nova logs required... thanks in advance

-Nithin

edit retag flag offensive close merge delete

Comments

Honestly you will have to provide a bit more logs for us to assist you.

Please run the instance using the CLI with a --debug switch, and provide the relevant compute logs from that exact time.

http://docs.openstack.org/openstack-o...

omar-munoz gravatar imageomar-munoz ( 2015-08-14 11:40:50 -0600 )edit

Are there any ERROR messages showing up in your nova logs? I would probably start with the nova-compute log on your compute hosts.

larsks gravatar imagelarsks ( 2015-08-14 20:12:02 -0600 )edit