Ask Your Question
1

can not sync database Ubuntu 15.04

asked 2015-08-10 14:35:52 -0600

BuildGuru gravatar image

Authentication fails controller_root@controller:~$ sudo su -s /bin/sh -c "keystone-manage db_sync" keystone 2015-08-10 14:24:46.623 26632 WARNING oslo_db.sqlalchemy.session [-] SQL connection failed. 10 attempts left. ^C Session terminated, terminating shell...2015-08-10 14:24:47.883 26632 CRITICAL keystone [-]

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
2

answered 2015-08-11 20:21:59 -0600

Senol Erdogan gravatar image

First, enable your SQL server's query loging. Then watch SQL logs while trying the sync command. If tjere is any mistake in keystone.conf then you will see if your connection credential right or not in SQL logs. If they are not same which in logs and conf file, probably "conmection" setting is at wrong place. Move sql connection information from [default] to [database] section.

Second, disable firewall or give permission where installed SQL server.

After solve the connection problem you can disable SQL query loging.

edit flag offensive delete link more
0

answered 2015-10-30 04:31:40 -0600

angegar gravatar image

I am encountering the same issue, did you find any solution.

As information, i am able to login in using the command "mysql -u keystone -p".

Thank you for the help that you migth bring.

++

edit flag offensive delete link more
0

answered 2015-08-11 02:57:05 -0600

bonclay7 gravatar image

Can you connect manually to your database with the parameters you provided in keystone.conf ?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-10 14:35:52 -0600

Seen: 604 times

Last updated: Aug 11 '15