Ask Your Question
0

cli auth posts to http://<IP>:35357/tokens instead of to http://<IP>:35357/v2.0/tokens

asked 2015-08-09 12:32:01 -0500

anonymous user

Anonymous

According to the API documentation, in order to authenticate, it needs to POST to keystone to to /v2.0/tokens, but keystone service-list POSTs to /tokens, and gets a 404. How can I fix this?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-08-09 14:25:50 -0500

Tobias Urdin gravatar image

Hello,

Make sure you have the environment variable OS_AUTH_URL set to your Keystone server and add v2.0 to the URL. Also please note that the python-keystoneclient ("keystone" CLI command) will be deprecated in the future and the new python-openstackclient ("openstack" CLI command) will take over so you should start using it right away.

So it will be:

openstack service list

Best regards

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-09 12:31:43 -0500

Seen: 88 times

Last updated: Aug 09 '15