Ask Your Question
-1

While adding image in glance, getting below error. Please help me..!!!

asked 2015-08-06 15:21:57 -0500

Branav gravatar image

updated 2015-08-10 14:09:56 -0500

smaffulli gravatar image

After adding glance image, I am getting following error:

glance add name=cirros-0.3.2-x86_64 is_public=true container_format=bare        \disk_format=qcow2 < cirros-0
.3.2-x86_64-disk.img
The request you have made requires authentication. (HTTP 401)

Here is my novarc.

export OS_TENANT_NAME=admin
export OS_USERNAME=admin
export OS_PASSWORD=password
export MYSQL_PASS=password
export SERVICE_PASSWORD=password
export RABBIT_PASSWORD=password
export FIXED_RANGE=10.0.0.0/24
export FLOATING_RANGE=172.20.1.224/27
export OS_AUTH_URL="http://controller:5000/v2.0/"
export SERVICE_ENDPOINT="http://controller:35357/v2.0"
export SERVICE_TOKEN=stackinsider
export MASTER=controller
export LOCAL_IP="192.168.10.5"

I'm trying to deploy openstack in stackinsider.

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-08-16 22:58:10 -0500

Mohit gravatar image

Ensure the novarc file looks like

export OS_TENANT_NAME=admin
export OS_USERNAME=admin
export OS_PASSWORD=password
export OS_AUTH_URL="http://x.y.z.a:5000/v2.0/"

Ensure that the OS_AUTH_URL is recognized by all nodes present in your openstack environment, Mainly this issue happens when the OS_AUTH_URL is incorrect. If this is the first time when you are importing the image to glance , Ensure that you can restart the glance service to confirm glance is working correctly , If not check the error using the parameter --debug

If glance does not restarts , Check the permission of all logs present on /var/log/glance and ensure the log file's ownership is set to glance glance

edit flag offensive delete link more
0

answered 2015-08-11 07:01:04 -0500

dbaxps gravatar image

Update you novarc file with :-

export OS_REGION_NAME=RegionOne
edit flag offensive delete link more
0

answered 2015-08-06 15:31:58 -0500

updated 2015-08-11 06:33:44 -0500

Source your user credentials.

I you have made a packstack installation

source keystonerc_admin

If you are installing manually following the official guides, you probably have created a file called admin-openrc.sh

source admin-openrc.sh

Regards

edit flag offensive delete link more

Comments

Thanks Eduardo...!!

After source novarc, Now am getting the following error - The request you have made requires authentication. (HTTP 401).

Below is my novarc file.

export OS_TENANT_NAME=admin export OS_USERNAME=admin export OS_PASSWORD=password export MYSQL_PASS=password export SERVICE_PASSWORD

Branav gravatar imageBranav ( 2015-08-06 15:41:27 -0500 )edit

I couldn't able to paste my entire novarc file. Is there any way, I can attach snap of it ?

Branav gravatar imageBranav ( 2015-08-06 15:42:49 -0500 )edit

Which Openstack version and OS are you using? You can paste it at paste.openstack.org Check the documentation for your OS and openstack version and see what parameters your file needs.

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-08-06 16:11:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-06 15:21:57 -0500

Seen: 165 times

Last updated: Aug 16 '15