Ask Your Question
0

packstack (Failed to find some config files: /etc/neutron/plugin.ini)

asked 2015-08-06 06:37:28 -0600

dmnord gravatar image

Hi, All

While installing https://repos.fedorapeople.org/repos/openstack/openstack-kilo/ (OpenStack Kilo from RDO repository) I've tried to install the one via openstack-packstack version 2015.1-0.10.dev1608.g6447ff7 and openstack-puppet-modules version 2015.1.9-4.

Deploying within the command packstack --debug --allinone finishes with error when the neutron manifest is in apply state.

System settings: Fedora 22 x86_64, RDO Openstack Kilo repository.

Main command output: http://www.datafilehost.com/d/68b936ce

Neutron manifest log: http://www.datafilehost.com/d/a928763f

What I have to do in order to the installation was successful?

Thanks!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-08-06 15:09:03 -0600

dbaxps gravatar image

updated 2015-08-06 15:28:53 -0600

Your error

Applying 192.168.100.33_neutron.pp
192.168.100.33_neutron.pp:                        [ ERROR ]          
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 192.168.100.33_neutron.pp
Notice: /Stage[main]/Neutron::Db::Sync/Exec[neutron-db-sync]/returns: oslo_config.cfg.ConfigFilesNotFoundError: Failed to find some config files: /etc/neutron/plugin.ini

is a known bug https://bugzilla.redhat.com/show_bug....
See, core issue fix :- https://review.openstack.org/#/c/209032/
Details here :- http://bderzhavets.blogspot.com/2015/...
Rebuild openstack-packstack-2015.1-0.10.dev1608.g6447ff7.fc23.src.rpm on Fedora 22
with patch 0002-Avoid-running-neutron-db-manage-twice

Place patch in SOURCES and update correspondingly spec file.
$ rpmbuild -bb openstack-packstack.spec
$ cd ../RPMS/noarch
$ sudo dnf install openstack-packstack-2015.1-0.10.dev1608.g6447ff7.fc22.noarch.rpm
openstack-packstack-doc-2015.1-0.10.dev1608.g6447ff7.fc22.noarch.rpm
openstack-packstack-puppet-2015.1-0.10.dev1608.g6447ff7.fc22.noarch.rpm

If it's hard to follow logic above , just before running packstack

# cd  /usr/lib/python2.7/site-packages/packstack/puppet/templates
Apply patch manually to neutron_api.pp. It's pretty simple.
edit flag offensive delete link more

Comments

Thanks so much! After applying the patch packstack has finished with success!

 **** Installation completed successfully ******
dmnord gravatar imagedmnord ( 2015-08-07 01:23:34 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-06 01:51:19 -0600

Seen: 1,113 times

Last updated: Aug 06 '15