Ask Your Question
0

Failure to create vxlan VMs, reporting that "gre" is not a valid network type

asked 2015-08-05 08:08:00 -0500

Peter White gravatar image

I have created a simple OpenStack juno deployment using OpenVSwitch and vxlan. I have checked that nowhere in any configuration file does "gre" appear, and yet when I create a VM I see the error below.

I suspect that the default tunnel type is GRE, and I have failed to set it on the controller. Setting both "tunnel_type" and "tunnel_types" to "vxlan" in the agent section of /etc/neutron/neutron.conf hasn't made any difference.

Can somebody please suggest what the problem might be and / or what configuration options to try?

2015-08-05 12:59:08.014 3015 ERROR oslo.messaging.rpc.dispatcher [req-891c6a44-40e8-49b7-a8b0-4300746cb40f ] Exception during message handling: Invalid input for operation: network_type value 'gre' not supported.
2015-08-05 12:59:08.014 3015 TRACE oslo.messaging.rpc.dispatcher Traceback (most recent call last):
2015-08-05 12:59:08.014 3015 TRACE oslo.messaging.rpc.dispatcher   File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 134, in _dispatch_and_reply
2015-08-05 12:59:08.014 3015 TRACE oslo.messaging.rpc.dispatcher     incoming.message))
2015-08-05 12:59:08.014 3015 TRACE oslo.messaging.rpc.dispatcher   File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 177, in _dispatch
2015-08-05 12:59:08.014 3015 TRACE oslo.messaging.rpc.dispatcher     return self._do_dispatch(endpoint, method, ctxt, args)
2015-08-05 12:59:08.014 3015 TRACE oslo.messaging.rpc.dispatcher   File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 123, in _do_dispatch
2015-08-05 12:59:08.014 3015 TRACE oslo.messaging.rpc.dispatcher     result = getattr(endpoint, method)(ctxt, **new_args)
2015-08-05 12:59:08.014 3015 TRACE oslo.messaging.rpc.dispatcher   File "/usr/lib/python2.7/dist-packages/neutron/plugins/ml2/drivers/type_tunnel.py", line 180, in tunnel_sync
2015-08-05 12:59:08.014 3015 TRACE oslo.messaging.rpc.dispatcher     raise exc.InvalidInput(error_message=msg)
2015-08-05 12:59:08.014 3015 TRACE oslo.messaging.rpc.dispatcher InvalidInput: Invalid input for operation: network_type value 'gre' not supported.
2015-08-05 12:59:08.014 3015 TRACE oslo.messaging.rpc.dispatcher
2015-08-05 12:59:08.015 3015 ERROR oslo.messaging._drivers.common [req-891c6a44-40e8-49b7-a8b0-4300746cb40f ] Returning exception Invalid input for operation: network_type value 'gre' not supported. to caller
2015-08-05 12:59:08.016 3015 ERROR oslo.messaging._drivers.common [req-891c6a44-40e8-49b7-a8b0-4300746cb40f ] ['Traceback (most recent call last):\n', '  File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 134, in _dispatch_and_reply\n    incoming.message))\n', '  File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 177, in _dispatch\n    return self._do_dispatch(endpoint, method, ctxt, args)\n', '  File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 123, in _do_dispatch\n    result = getattr(endpoint, method)(ctxt, **new_args)\n', '  File "/usr/lib/python2.7/dist-packages/neutron/plugins/ml2/drivers/type_tunnel.py", line 180, in tunnel_sync\n    raise exc.InvalidInput(error_message=msg)\n', "InvalidInput: Invalid input for operation: network_type value 'gre' not supported.\n"]
edit retag flag offensive close merge delete

Comments

Check in ml2_conf.ini

[ml2]
type_drivers = vxlan,gre
tenant_network_types = gre
dbaxps gravatar imagedbaxps ( 2015-10-19 10:35:36 -0500 )edit

GRE is not default type_drivers as well as tenant_network_types.

dbaxps gravatar imagedbaxps ( 2015-10-19 10:38:29 -0500 )edit

I didn't have gre in either of those files, but no longer have all the config (I nuked the deployment because I could never get it working), so no longer have access to the exact content.

Peter White gravatar imagePeter White ( 2015-10-26 05:53:50 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-10-19 09:35:42 -0500

br gravatar image

updated 2015-10-19 10:32:35 -0500

dbaxps gravatar image

`Please check whether following configuration present in ml2.conf.ini:

 [ovs]
    local_ip = <INSTANCE_TUNNEL_INTERFACE_IP_ADDRESS>
    tunnel_type = vxlan
    tunnel_bridge = br-tun
    integration_bridge = br-int
    tunnel_id_ranges = 65537:69999
    tenant_network_type = vxlan
    enable_tunneling = true

[agent]
root_helper = sudo neutron-rootwrap /etc/neutron/rootwrap.conf
tunnel_types = vxlan
vxlan_udp_port = 4789`
edit flag offensive delete link more

Comments

I think I did have those, but can no longer be sure - the deployment no longer exists.

Peter White gravatar imagePeter White ( 2015-10-26 05:54:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-05 08:08:00 -0500

Seen: 1,000 times

Last updated: Oct 19 '15