Ask Your Question
3

Instance failed network setup - ValueError: too many values to unpack

asked 2013-12-02 08:56:45 -0500

Andriy Yurchuk gravatar image

updated 2013-12-03 01:59:16 -0500

I've configured an OpenStack installation as per the this guide: http://docs.openstack.org/havana/install-guide/install/apt/content/ch_preface.html

I have a controller node, a compute node and a network node. This is what my Neutron networks look like: https://gist.github.com/Ch00k/7750605

When I try to create an instance using int-net I get the following error: https://gist.github.com/Ch00k/7750554

I'm not sure what additional information I need to provide here so please let me know. I will be thankful for any thoughts on how to debug this.

The command I'm using is the following:

nova boot --flavor 1 --key_name mykey --image 86c9c0d0-1e0d-4650-99b0-eec680e20d24 --security_group default --nic net-id=79c80b7a-fe9e-4aff-97bc-475ef23910b4 cirrOS

If I use ext-net instead of int-net the error is the same.

edit retag flag offensive close merge delete

Comments

How are you starting the instance? If you're using the `nova` cli, can you post the exact command you're using?

larsks gravatar imagelarsks ( 2013-12-02 21:40:04 -0500 )edit

I updated the topic and added a command I use.

Andriy Yurchuk gravatar imageAndriy Yurchuk ( 2013-12-03 01:59:51 -0500 )edit

Hey, Andriy. I'm getting the same issue when creating an instance on a neutron subnet. However, my resources are split up a little differently. I have my network services running on my controller. Are you using flat networking?

elextro gravatar imageelextro ( 2013-12-03 11:53:28 -0500 )edit

I am facing the same issue and I am using the same guide, Where have you created the net and sub net when setting base neutron network? on the controller node or network node? have you set the demo_net sub net ip to same CIDR as data_interface?

Muhammad Wasay gravatar imageMuhammad Wasay ( 2013-12-04 10:05:10 -0500 )edit

Same issue here, using the same guide. I'm using a flat network w/neutron.

raspinall gravatar imageraspinall ( 2013-12-04 10:23:59 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-07-03 03:41:07 -0500

fifieldt gravatar image

So, the Havana install guide for Neutron and Neutron itself probably had a few bugs.

Since we now have 3 more releases after that one, if you are seeing this, I would recommend trying a new release - the neutron install guide is very well tested and you should not get errors like this.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2013-12-02 08:56:45 -0500

Seen: 408 times

Last updated: Jul 03 '15