Ask Your Question
0

Devstack Neutron - Router GW IP Issues

asked 2015-08-04 07:20:05 -0500

olly gravatar image

updated 2015-08-04 07:48:44 -0500

SGPJ gravatar image

Hey All,

Trying to install Devstack in my environment with neutron on a single node. I'm having trouble when running stack.sh with an error "Failure retrieving ROUTER_GW_IP". After browsing google for a while I have ran out of ideas....

I think the problem arises due to me having to change the fixed network to a new range, the default fixed range of 10.0.0.0 range conflicts with my desired floating range and external environment.

Stack.sh error:

2015-08-04 10:58:19.557 | ++ grep router_gateway 
2015-08-04 10:58:20.403 | + ROUTER_GW_IP= 
2015-08-04 10:58:20.403 | + die_if_not_set 1319 ROUTER_GW_IP 'Failure retrieving ROUTER_GW_IP' 
2015-08-04 10:58:20.403 | + local exitcode=0 
2015-08-04 10:58:20.405 | [Call Trace] 
2015-08-04 10:58:20.406 | ./stack.sh:1244:create_neutron_initial_network
2015-08-04 10:58:20.406 | /devstack/lib/neutron-legacy:597:_neutron_configure_router_v4
2015-08-04 10:58:20.406 | /devstack/lib/neutron-legacy:1319:die_if_not_set
2015-08-04 10:58:20.406 | /devstack/functions-common:135:die
2015-08-04 10:58:20.408 | [ERROR] /devstack/functions-common:1319 Failure retrieving ROUTER_GW_IP
2015-08-04 10:58:21.411 | Error on exit

local.conf snippets:

FLOATING_RANGE=10.49.1.1/24
FIXED_RANGE=192.168.0.1/24
NETWORK_GATEWAY=192.168.0.1
PUBLIC_NETWORK_GATEWAY=10.49.1.1
Q_FLOATING_ALLOCATION_POOL=start=start=10.49.1.80,end=10.49.1.90
PUBLIC_INTERFACE=eth0

disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service q-meta

Thanks in advance :)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-08-04 10:19:22 -0500

mpetason gravatar image

Your floating range should use a network address, otherwise the gateway isn't within it unless it takes the network address. It looks like you are using this:

FLOATING_RANGE=10.49.1.1/24

But should be using:

FLOATING_RANGE=10.49.1.0/24

The same would be true for your Fixed range. Network addresses should include the first address in the range : 0 followed by the slash notation.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-04 07:20:05 -0500

Seen: 1,368 times

Last updated: Aug 04 '15