Ask Your Question
0

RDOS KILO - Unable to create VLAN external network

asked 2015-08-04 06:31:20 -0500

manubalasree gravatar image

updated 2015-08-14 11:12:41 -0500

rbowen gravatar image
$ neutron net-create --tenant-id services  --shared --router:external --provider:network_type VLAN --provider:physical_network default --provider:segmentation_id 150 ext

Invalid input for operation: network_type value 'VLAN' not supported.
edit retag flag offensive close merge delete

Comments

1

Could you post your ml2_conf.ini from Network Node.
type_drivers=?

dbaxps gravatar imagedbaxps ( 2015-08-04 06:58:28 -0500 )edit

Yes, you need to post the data from Ml2. Ensure that you have configured the allowed types as well, and that you have enough segmentation IDs to cover all of the networks you are creating.

mpetason gravatar imagempetason ( 2015-08-04 10:20:52 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-04-20 04:59:16 -0500

Hynek gravatar image

The letter case matters when specifying provider:network_type, ensure you use vlan instead of VLAN:

neutron net-create --tenant-id services  --shared --router:external --provider:network_type vlan --provider:physical_network default --provider:segmentation_id 150 ext
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-04 06:31:20 -0500

Seen: 661 times

Last updated: Aug 14 '15