Ask Your Question
0

when i attach volume to instance,got error VolumeBackendAPIException

asked 2015-08-04 03:19:42 -0500

slosh_liuxin gravatar image

updated 2015-08-04 03:23:18 -0500

I use openstack kilo,and my server is centos 7.1 64bit.I can start an instance,when I attach a volume(cinder) to my instacne,I have got error like this: image description Please who can tell me,what is the problem?And what should i do for troubleshooting? cinder.conf on block server: image description

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-08-04 19:06:16 -0500

slosh_liuxin gravatar image

updated 2015-08-04 19:06:55 -0500

Eduardo Gonzalez,

-

   I really thank you for helping me to troubleshooting!With your help,i check again the cinder.conf from both controller and block server.The problem is at block server, i start tgtd.service with iscsi_helper=lioadm,which this is wrong!I stop tgtd.service,and restart openstack-cinder-volume.service target.service,then i attach the volume to the instance,it is OK!
   This is all my fault,your are a very good man! Thank you very much!
   Can i got your email please?Because I am an newer of openstack,problems will  got a lots,i wish someone  can talk about each other with them.BTW,thanks again!
edit flag offensive delete link more
0

answered 2015-08-04 03:53:33 -0500

updated 2015-08-04 03:55:12 -0500

Hi. You have forgot the section lvm and the following options inside it:

[lvm]
...
volume_driver = cinder.volume.drivers.lvm.LVMVolumeDriver
volume_group = cinder-volumes
iscsi_protocol = iscsi
iscsi_helper = lioadm

Create this section and move that options inside.

Reference guide: http://docs.openstack.org/kilo/install-guide/install/yum/content/cinder-install-storage-node.html

Regards

edit flag offensive delete link more

Comments

Thank u very much! This is my fault.But,when i add the [lvm] options,i restart openstack-cinder-volume.service tgtd.service lvm2-lvmetad.service target.service,the error is still there...... I am crazy......Man,please help me......

slosh_liuxin gravatar imageslosh_liuxin ( 2015-08-04 04:06:21 -0500 )edit

Paste cinder.conf at controller node, and logs from cinder in both nodes. Better if is a code paste, not an image because is harder to read. Also check if all is OK at cinder service-list from controller node. If not, paste related logs from the bad service.

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-08-04 04:19:16 -0500 )edit

Eduardo Gonzalez I really thank you for helping me to troubleshooting!.Can i got your email please?Because I am an newer of openstack,problems will got a lots,i wish someone can talk about each other with them.BTW,thanks again!

slosh_liuxin gravatar imageslosh_liuxin ( 2015-08-04 19:36:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-04 03:19:42 -0500

Seen: 466 times

Last updated: Aug 04 '15