Ask Your Question
0

windows instance freezes after attaching a cinder volume

asked 2015-08-03 12:29:51 -0500

BuildGuru gravatar image

Once i attach a drive to a windows instance. It completely freezes, what could be the problem?

2015-08-03 13:26:28.211 1752 INFO nova.virt.xenapi.volumeops [req-a39173d7-ee3b-4fa5-9cc3-0fb452e23291 None] Dev 1 attached to instance instance-0000000a

edit retag flag offensive close merge delete

Comments

I dont have VirtIO installed on the Windows instance. I installed Cloudinit base http://www.cloudbase.it/cloud-init-wi... should i install VirtIO ? from where ?

BuildGuru gravatar imageBuildGuru ( 2015-08-04 10:44:23 -0500 )edit
mpetason gravatar imagempetason ( 2015-08-04 11:35:12 -0500 )edit

This is just for KVM, you know im using Xen right ?

BuildGuru gravatar imageBuildGuru ( 2015-08-04 14:54:37 -0500 )edit

All the images come with the required hypervisor specific drivers and tools, for example VirtIO for KVM and XenServer tools for XenServer / XCP. http://www.cloudbase.it/windows-cloud...

BuildGuru gravatar imageBuildGuru ( 2015-08-04 15:46:11 -0500 )edit

I already had XenTools installed !!!

BuildGuru gravatar imageBuildGuru ( 2015-08-04 15:46:36 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2015-08-25 07:21:49 -0500

Bob Ball gravatar image

There is a bug in XS 6.5 in the iSCSI SR – try modifying the iscsi SR on the xenserver with the following: https://github.com/citrix-openstack/q...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-03 12:29:51 -0500

Seen: 161 times

Last updated: Aug 25 '15