Ask Your Question
0

Hyper-V compute - not booting instances no network interface

asked 2015-08-02 11:38:18 -0500

eboda gravatar image

updated 2015-08-05 13:43:36 -0500

I have a Hyper-V compute node which was setup by the cloudbase.it installer. I manage to create instances and they show up correctly and are bootable. But there are 2 problems:

  1. My dashboard shows them as (stuck at) "Spawning..." and they do not boot automatically. (I have to boot them via HyperV manager.
  2. No network interfaces are assigned to the VMs and even if I manually assign one, there is no connectivity.

I don't know at all how to troubleshoot this issue. Please tell me the logs/configs you would need to see from me and I can provide them!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-08-02 19:33:07 -0500

alexpilotti gravatar image

In order to help you with the troubleshooting, can you please provide nova-compute and neutron-hyperv-agent logs from the Hyper-V node? Best is if you cold post them for readability on http://paste.openstack.org and add the generated links here.

Are you using Neutron or Nova network? What type of network (flat, vlan, vxlan, gre) are you trying to attach?

edit flag offensive delete link more

Comments

I am trying to use nova-network FlatDHCP. Not quite sure how to go about that on hyperv. I have another compute node set up with nova-network and vmware as hypervisor. Those work fine. Now I just have to add my hyperv compute somehow into this equation... Logs: http://paste.openstack.org/show/409209

eboda gravatar imageeboda ( 2015-08-05 13:43:19 -0500 )edit

here is also a picture of how it looks like on HyperV after creating the VM in the logs: http://i.imgur.com/6LcM8al.png (just ignore the test VM). As you can see the VM did not get a network adapter assigned. Thanks for any help

eboda gravatar imageeboda ( 2015-08-05 13:49:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-08-02 11:38:18 -0500

Seen: 161 times

Last updated: Aug 05 '15