cinder to use ceph storage

asked 2015-08-01 02:21:59 -0600

chandan gravatar image

Dear Team, I successfully integrate the openstack and ceph , and also configure cinder.conf file to use ceph but when we create volumes it will not show in rbd volumes pools.

plz provide me the exact solution for the same.


edit retag flag offensive close merge delete


Please, paste cinder.conf and cinder service-list output.

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-08-01 02:31:46 -0600 )edit

I paste cinder.conf file --- [root@controller1 ceph(keystone_admin)]# cinder service-list

ERROR: The request you have made requires authentication. (HTTP 401) (Request-ID: req-82c0bc80-bc11-48a3-a054-cfd75f049fa9)

chandan gravatar imagechandan ( 2015-08-01 02:46:55 -0600 )edit

plz provide the solution for the same

chandan gravatar imagechandan ( 2015-08-01 04:13:53 -0600 )edit

I paste cinder.conf file ---

chandan gravatar imagechandan ( 2015-08-01 05:52:36 -0600 )edit

If you are unable to make requests, share with us more information about keystone logs and make the request with --debug option. If the error is not related to this question, create another question. Regards

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-08-01 15:38:56 -0600 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2015-10-29 09:21:45 -0600

keerthivasanselvaraj gravatar image

Thanks for your inputs..

I am trying to use ceph as a volume backend for cinder. I setup a ceph cluster in a single virtual machine with osd and monitor and the osd status is up. (working fine)

while creating the cinder volume it enters in to error state and it is not in to the rbd volumes pool.

my api.log -------------- scheduler.log -----------

In scheduler " No valid host was found and No weight is found" error is facing. please help me.

cinder type-list for ceph is --- id| 1ebe7c72-6d15-4213-9644-c0b21eb52960 | ceph |


All cinder services are up cinder-volume for ceph is up and i disable lvm (enable_backends)

Thanks in advance...

edit flag offensive delete link more

answered 2015-08-01 15:36:18 -0600

Hi, enabled_backends option is configured to use lvm, change it for rbd and under "Options defined in cinder.volume.drivers.rbd" create the section [rbd]

"Options defined in cinder.volume.drivers.rbd"

With this content cinder must be using ceph rbd as backend, the error "ERROR: The request you have made requires authentication. (HTTP 401)" i don't know where it comes with no information, source again keystonerc_admin and try it again, sometimes env variables are not correctly sourced, if that don't work, please share more information.


edit flag offensive delete link more


I enabled_backends=rbd and create section[rbd] under "Options defined in cinder.volume.drivers.rbd" , but when we restart the cinder-volume service it will give error in volume.log . I attach that in

chandan gravatar imagechandan ( 2015-08-03 03:44:38 -0600 )edit

A better output is tail -n50 volume.log, with this log barely cant see nothing, attach api.log too

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-08-03 05:28:23 -0600 )edit

I attach the log and

chandan gravatar imagechandan ( 2015-08-03 05:54:06 -0600 )edit

Maybe is a bug , try upgrading packages. whats the output of systemctl status -l openstack-cinder-volume.service?

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-08-03 06:55:30 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-08-01 02:21:59 -0600

Seen: 731 times

Last updated: Oct 29 '15