Ask Your Question
1

Packstack error since 7/30 related to python-oslo-vmware

asked 2015-07-31 00:28:13 -0600

ggont gravatar image

Hello,

I have been using a setup to practice for RHEL EX210. I am using virt-manager to create v-machines where I install Centos7 minimal. Then I installed:

yum install -y http://rdoproject.org/repos/openstack... yum install -y openstack-packstack.

Last time successful was 29/7. Since 07/30 I get the following error from packstack installing glance. (Check attached screenshot).

I checked here https://repos.fedorapeople.org/repos/... and I can see that this was modified the same day.

python-oslo-vmware-0.7.0-1.el7.noarch.rpm 2015-07-30 22:03 70K Screenshot_centos7.0_2015-07-31_00:22:25.png

I don't think it is a coincidence. I need to install Juno because training was based on that. Appreciate any help!!!

edit retag flag offensive close merge delete

Comments

What happens when yum install python-oslo-vmware-0.7.0-1.el7.noarch.rpm runs via CLI ?

dbaxps gravatar imagedbaxps ( 2015-07-31 02:08:58 -0600 )edit

It fails. I tried to install it before running packstack and it complains it requires python-iso8601

ggont gravatar imageggont ( 2015-08-01 11:51:03 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-08-03 08:58:16 -0600

ggont gravatar image

Hello,

The issue was fixed in new python-oslo-vmware released on 7/31. Here is more information:

http://cbs.centos.org/koji/buildinfo?...

edit flag offensive delete link more
1

answered 2015-07-31 02:52:52 -0600

tahder gravatar image

updated 2015-07-31 04:01:00 -0600

dbaxps gravatar image

It is related to conflict with the python-request, incompatibilities. It just started today this issue with Juno as no problems in Kilo..

If you try to update you can get similar to this..

--> Running transaction check
---> Package kernel.x86_64 0:3.10.0-123.el7 will be erased
---> Package python-oslo-vmware.noarch 0:0.7.0-1.el7 will be an update
--> Processing Dependency: python-request for package: python-oslo-vmware-0.7.0-                                                                                                                     1.el7.noarch
--> Finished Dependency Resolution
Error: Package: python-oslo-vmware-0.7.0-1.el7.noarch (openstack-juno)
           Requires: python-request
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
edit flag offensive delete link more

Comments

My solution, disable first the Juno Repository and then update it. Once updated, enable back Juno repository and lastly rerun the packstack which mine work fine.

tahder gravatar imagetahder ( 2015-07-31 04:46:30 -0600 )edit

I get the same error when I try to install python-oslo-vmware. Could you explain the solution please? Disable Juno Rep (how to do it) and then do yum install python-oslo-vmware-0.7.0-1.el7.noarch?

Is this a bug? Will it get fixed?

ggont gravatar imageggont ( 2015-07-31 09:59:36 -0600 )edit

Where else can I install this version of python-oslo? Are they going to fix the dependency in juno-repo or noone works on it anymore?

ggont gravatar imageggont ( 2015-08-01 12:16:24 -0600 )edit
1

Found out they released a new version on July 31st. Comments say it fixes python-request issue.
http://cbs.centos.org/koji/buildinfo?...

ggont gravatar imageggont ( 2015-08-01 13:35:07 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-07-31 00:28:13 -0600

Seen: 222 times

Last updated: Aug 03 '15