Ask Your Question
1

Unable to use filesystem_store_datadirs in Glance Kilo

asked 2015-07-30 14:11:26 -0500

rzhelion gravatar image

I am trying to add some disk space to my configuration for images and snapshots. When I add the following to glance-api.conf -

[glance_store]
# filesystem_store_datadir=/var/lib/glance/images/    
filesystem_store_datadirs = /var/lib/glance/images
filesystem_store_datadirs = /var/lib/glance/images-lvm:100

I am unable to add new images or snapshots because I see the error:

2015-07-30 14:59:26.645 11038 WARNING oslo_config.cfg [-] Option "filesystem_store_datadir" from group "DEFAULT" is deprecated. Use option "filesystem_store_datadir" from group "glance_store". 2015-07-30 14:59:26.646 11038 ERROR glance_store._drivers.filesystem [-] Specify either 'filesystem_store_datadir' or 'filesystem_store_datadirs' option 2015-07-30 14:59:26.647 11038 WARNING glance_store.driver [-] Failed to configure store correctly: Store filesystem could not be configured correctly. Reason: Specify either 'filesystem_store_datadir' or 'filesystem_store_datadirs' option Disabling add method.

I have commented out "filesystem_store_datadir" from the [glance_store} section and don't have any other occurrences of this parameter in the file.

This is RDO Kilo allinone on Centos-7

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-07-30 14:45:11 -0500

You have to leave empty "filesystem_store_datadir=", do not comment it because it will use the default value which causes conflicts.

filesystem_store_datadir=

filesystem_store_datadirs=/var/lib/glance/images
filesystem_store_datadirs=/var/lib/glance/images-lvm:100

Regards

edit flag offensive delete link more

Comments

That corrected my initial issue, but now I get:

2015-07-30 16:03:47.867 24418 ERROR glance_store._drivers.filesystem [-] Permission to write in /var/lib/glance/images-lvm denied

# ls -ld *lvm
drwxr-x---. 2 glance glance 6 Jul 30 16:26 images-lvm

any ideas?

rzhelion gravatar imagerzhelion ( 2015-07-30 15:37:06 -0500 )edit

Check if the device mount attributes has rw permissions

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-07-30 15:52:44 -0500 )edit

Turns out is was selinux. Had to switch to permissive mode to get it to work. Any ideas on what needs to be done for selinux when adding back end file systems?

rzhelion gravatar imagerzhelion ( 2015-08-04 20:33:21 -0500 )edit

It depends of what backend you want to use, but for set permissive only cinder processes use.

semanage permissive -a cinder_volume_t

https://www.mankier.com/8/cinder_volume_selinux

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-08-05 01:54:46 -0500 )edit

Also, ensure that openstack-selinux package is installed and updated

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-08-05 02:02:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-07-30 14:11:26 -0500

Seen: 1,000 times

Last updated: Jul 30 '15