ceph + openstack integration

asked 2015-07-29 08:08:18 -0600

anonymous user


Hi all I integrated ceph with openstack rdo kilo . But when we create a image then it will not view in rados -p images ls.

Plz help me . what we do for that.


edit retag flag offensive close merge delete


Are you using multi backend for glance? maybe the images are uploaded in local storage. Check if "default_store=rbd" at glance-api.conf is properly configured

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-07-29 14:23:38 -0600 )edit

yes, the images is store in local storage . the default_store=rbd is properly configured in glance-api.conf.

chandan gravatar imagechandan ( 2015-07-30 03:58:47 -0600 )edit

Can you try using "--store rbd" option when create an image?

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-07-30 04:24:30 -0600 )edit

when i create an image from cmd we get error thos one : - - - [root@controller1 ~(keystone_admin)]# glance image-create --name ubuntu --disk-format qcow2 --store rbd --container-format bare --is-public True < precise-server-cloudimg-amd64-disk1.img The request you have made requires authentication.

chandan gravatar imagechandan ( 2015-07-30 07:35:58 -0600 )edit

Is there any suspicious log at glance, keystone or ceph? ceph.client.glance.keyring is owned by glance user and with the right permissions at ceph? Also can you paste glance-api.conf file at paste.openstack.org Regards

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-07-30 08:29:07 -0600 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2015-07-30 10:19:38 -0600

I'm seeing that the "stores = rbd" is missing under [glance store], that's the way you probably can create images in local. The second thing i see is that the keyrings are not named as they should:


This can cause your "The request you have made requires authentication" message.

Here you have a link for the ceph integration: http://ceph.com/docs/master/rbd/rbd-openstack/#configure-openstack-to-use-ceph


edit flag offensive delete link more


when I add stores = rbd in glance-api.conf file and restart service then it gives error - [root@controller1 ~(keystone_admin)]# service openstack-glance-api restart Redirecting to /bin/systemctl restart openstack-glance-api.service Job for openstack-glance-api.service failed. See 'systemctl status

chandan gravatar imagechandan ( 2015-07-31 04:16:22 -0600 )edit

I attach the api.log file and glance-api.conf ------http://paste.openstack.org/show/406555/ http://paste.openstack.org/show/406557 , http://paste.openstack.org/show/406559/. Help me.

chandan gravatar imagechandan ( 2015-07-31 04:19:35 -0600 )edit

stores=rbd not stores=glance.store.rbd.Store

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-07-31 04:26:50 -0600 )edit

I also try stores=rbd but again glance-api service fail to start

chandan gravatar imagechandan ( 2015-07-31 04:35:01 -0600 )edit

The same error in logs or another?

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-07-31 05:14:40 -0600 )edit

answered 2015-07-29 08:14:41 -0600


Are you able to list the images with the following command?

rbd ls images
edit flag offensive delete link more


i use this command also but no images is shown .

chandan gravatar imagechandan ( 2015-07-29 08:19:37 -0600 )edit

Are you using Ceph for glance image storage, or was it only configured to be used for volumes? What does the following give you:

ceph osd lspools
raul.flores gravatar imageraul.flores ( 2015-07-29 08:28:28 -0600 )edit

I use ceph for both glance and volume.

[root@controller1 ~]# ceph osd lspools 0 data,1 metadata,2 rbd,4 .rgw.root,5 .rgw.control,6 .rgw,7 .rgw.gc,8 .users.uid,9 .users,10 .users.swift,11 .users.email,12 .rgw.buckets.index,13 .rgw.buckets,14 StoragePool,15 volumes,16 images,17 backups,18 vms,

chandan gravatar imagechandan ( 2015-07-30 00:11:55 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2015-07-29 08:08:18 -0600

Seen: 737 times

Last updated: Jul 30 '15