Ask Your Question
1

Cannot start service : openstack-nova compute-node juno (release)

asked 2015-07-25 20:30:20 -0500

Anario gravatar image

updated 2015-07-27 01:41:41 -0500

after installation nova on my compute server i got this error

systemctl start libvirtd.service openstack-nova-compute.service

-- Logs begin at Sat 2015-07-25 18:07:08 PDT, end at Sat 2015-07-25 18:17:20 PDT. --
Jul 25 18:17:19 compute nova-compute[11869]: oslo.config.cfg.ConfigFileParseError: Failed to parse      /etc/nova/nova.conf: at /etc/nova/nova.conf:80, Section must be start
Jul 25 18:17:19 compute systemd[1]: openstack-nova-compute.service: main process exited, code=exited, status=1/FAILURE
Jul 25 18:17:19 compute systemd[1]: Failed to start OpenStack Nova Compute Server.
-- Subject: Unit openstack-nova-compute.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
 -- Unit openstack-nova-compute.service has failed.
 --
 -- The result is failed.

nova.conf

(standard input):rabbit_host=controller
(standard input):rabbit_password=passw0rd
(standard input):rpc_backend=rabbit
(standard input):my_ip=192.168.75.61
(standard input):auth_strategy=keystone
(standard input):verbose=true
(standard input):novncproxy_base_url=http://controller:6080/vnc_auto.html
(standard input):vncserver_listen=0.0.0.0
(standard input):vncserver_proxyclient_address=192.168.75.61
(standard input):vnc_enabled=true
(standard input):[baremetal]
(standard input):[cells]
(standard input):[cinder]
(standard input):[conductor]
(standard input):[ephemeral_storage_encryption]
(standard input):[glance]
(standard input):host=controller
(standard input):[hyperv]
(standard input):[image_file_url]
(standard input):[ironic]
(standard input):[keymgr]
 (standard input):[keystone_authtoken]
(standard input):auth_uri=http://controller:5000/v2.0
(standard input):identity_uri=http://controller:35357
(standard input):admin_tenant_name=service
(standard input):admin_user=nova
(standard input):admin_password=nova
(standard input):[libvirt]
(standard input):[matchmaker_redis]
(standard input):[matchmaker_ring]
(standard input):[metrics]
(standard input):[neutron]
(standard input):[osapi_v3]
(standard input):[rdp]
(standard input):[serial_console]
(standard input):[spice]
(standard input):[ssl]
(standard input):[trusted_computing]
(standard input):[upgrade_levels]
(standard input):[vmware]
(standard input):[xenserver]
(standard input):[zookeeper]

I also found this error

ABRT has detected 1 problem(s). For more info run: abrt-cli list --since 1437872994
[root@compute ~]# ABRT has detected 1 problem(s). For more info run: abrt-cli list --since 1437872994
-bash: syntax error near unexpected token `('
[root@compute ~]# abrt-cli list --since 1437872994
id 9ac4dd9d48dfa62f887b0f40b12a9596c8ae3244
reason: cfg.py:1307:_parse_file:ConfigFileParseError: Failed to parse /etc/nova/nova.conf: at              /nova/nova.conf:80, Section must be started before assignment: None
time:Sat 25 Jul 2015 05:29:05 PM PDT
cmdline:        /usr/bin/python /usr/bin/nova-compute
package:        openstack-nova-compute-2014.2.2-1.el7
uid:            162 (nova)
count:          11
Directory:      /var/spool/abrt/Python-2015-07-25-17:29:05-5373

and i couldn't find -bash: syntax error near unexpected token `('

any idea ?

edit retag flag offensive close merge delete

Comments

Could you upload somewhere /etc/nova/nova.conf as text file and provide the link ( line 80 has an error) . Also, even picture above is missing "virt_type".

dbaxps gravatar imagedbaxps ( 2015-07-26 06:00:10 -0500 )edit

Hello dbaxps here is my conf file http://pastebin.com/pfjxLc7T

Anario gravatar imageAnario ( 2015-07-26 15:34:15 -0500 )edit

I use it from openstack's manual Start the Compute service including its dependencies and configure them to start automatically when the system boots:

# systemctl enable libvirtd.service openstack-nova-compute.service
# systemctl start libvirtd.service openstack-nova-compute.service
Anario gravatar imageAnario ( 2015-07-26 15:36:54 -0500 )edit

If you intend start 2 services :-

systemctl start libvirtd ;
systemctl status  libvirtd ;
systemctl start openstack-nova-compute ;
systemctl status  openstack-nova-compute
dbaxps gravatar imagedbaxps ( 2015-07-26 15:37:07 -0500 )edit

[root@compute nova]# systemctl start openstack-nova-compute Job for openstack-nova-compute.service failed. See 'systemctl status openstack-nova- compute.service' and 'journalctl -xn' for details.

same ...

Anario gravatar imageAnario ( 2015-07-26 15:45:19 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
2

answered 2015-07-27 03:24:43 -0500

foexle gravatar image

It seems you missed the [DEFAULT] section header. If not, anything is wrong with your nova.conf, it's a parsing error.

Cheers Heiko

edit flag offensive delete link more
1

answered 2017-07-02 02:18:46 -0500

Pranay Sagar gravatar image

May be your problem is more related to firewall.

Run this command on your compute and controller node

1 systemctl disable firewalld
2 systemctl stop firewalld 3 systemctl start openstack-nova-compute.service To check the output run this command systemctl status openstack-nova-compute.service

โ— openstack-nova-compute.service - OpenStack Nova Compute Server Loaded: loaded (/usr/lib/systemd/system/openstack-nova-compute.service; enabled; vendor preset: disabled) Active: active (running) since Sun 2017-07-02 12:27:30 IST; 10min ago Main PID: 15476 (nova-compute) CGroup: /system.slice/openstack-nova-compute.service โ””โ”€15476 /usr/bin/python2 /usr/bin/nova-compute

Jul 02 12:26:19 compute systemd[1]: Starting OpenStack Nova Compute Server... Jul 02 12:26:29 compute nova-compute[15476]: Option "verbose" from group "DEFAULT" is deprecated ...re. Jul 02 12:27:30 compute nova-compute[15476]: /usr/lib/python2.7/site-packages/pkg_resources/__init__... Jul 02 12:27:30 compute nova-compute[15476]: stacklevel=1, Jul 02 12:27:30 compute systemd[1]: Started OpenStack Nova Compute Server. Hint: Some lines were ellipsized, use -l to show in full.

if this will not solve your problem kindly paste your nova.conf I will provide support to it

edit flag offensive delete link more
0

answered 2015-07-27 04:45:10 -0500

RAHUL1603 gravatar image

Yes there is no default section. Add it and if still error persist, check for the line number / error mentioned in the log file.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-07-25 20:30:20 -0500

Seen: 4,129 times

Last updated: Jul 02 '17