Ask Your Question
0

Create the service entity and API endpoint

asked 2015-07-22 09:03:43 -0500

mehdi-alisoltani-u gravatar image

updated 2015-07-23 02:26:32 -0500

Dears all

I am installing openstack Kilo following installation guide for ubuntu 14.04 .

I preformed the installation and configuration step by step and everything were fine until i wanted to create the service entity and API endpoint installation guide when i run the command

openstack service create  --name keystone --description "OpenStack Identity" identity

i face to the following error .....

Traceback (most recent call last):
  File "/usr/bin/openstack", line 10, in <module>
    sys.exit(main())
  File "/usr/lib/python2.7/dist-packages/openstackclient/shell.py", line 342, in main
    return OpenStackShell().run(argv)
  File "/usr/lib/python2.7/dist-packages/openstackclient/shell.py", line 79, in __init__
    command_manager=commandmanager.CommandManager('openstack.cli'))
  File "/usr/lib/python2.7/dist-packages/cliff/app.py", line 74, in __init__
    self._set_streams(stdin, stdout, stderr)
  File "/usr/lib/python2.7/dist-packages/cliff/app.py", line 82, in _set_streams
    locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib/python2.7/locale.py", line 579, in setlocale
    return _setlocale(category, locale)
locale.Error: unsupported locale setting

please someone tell me where this error come from and how to fix it

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
1

answered 2015-07-23 02:40:06 -0500

Yeah, it seems that you locales are not configured properly. Foexle is right. A little advice, you can view a list of available locales with the locale -a. Run these commands to get rid of errors. sudo apt-get install language-pack-en-base and then reconfiguring them by sudo dpkg-reconfigure locales.

edit flag offensive delete link more
1

answered 2015-07-23 01:29:15 -0500

foexle gravatar image

looks like your locales are not configured well on your system.

Check

/var/lib/locales/supported.d/local or /var/lib/locales/supported.d/en

check your language in my case i'm using

de_DE.UTF-8 UTF-8
en_US.UTF-8 UTF-8

and reconfigure your locales

dpkg-reconfigure locales

Hope it helps
Cheers

edit flag offensive delete link more

Comments

thank you worked

mehdi-alisoltani-u gravatar imagemehdi-alisoltani-u ( 2015-07-27 03:06:43 -0500 )edit
0

answered 2015-08-26 09:03:59 -0500

tiagoor gravatar image

I also solved this kind of problem adding/checking these vars: LANG="en_US.UTF-8" LANGUAGE="en_US.UTF-8" LC_ALL="en_US.UTF-8" in this file "/etc/default/locale"

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-07-22 09:03:43 -0500

Seen: 370 times

Last updated: Jul 23 '15