Ask Your Question
2

Kilo install error: Create the service entity for the Identity service

asked 2015-07-21 12:16:01 -0500

ivarh gravatar image

updated 2015-07-21 19:21:18 -0500

As the install guide states on page 37 - I am entering:

$ openstack service create --name keystone --description "OpenStack Identity" identity

It errors with this message: usage: openstack service create [-h] [-f {shell,table}] [-c COLUMN] [--variable VARIABLE] [--prefix PREFIX] --type <service-type> [--description <service-description>] <service-name> openstack service create: error: argument --type is required

Is there a type argument that is missing?

When I guess and change the syntax around I get an error from apache - this is the log:

2015-07-21 18:52:45.069133 mod_wsgi (pid=14291, process='keystone-admin', application=''): Loading WSGI script '/var/www/cgi-bin/keystone/admin'. 2015-07-21 18:52:45.069821 mod_wsgi (pid=14291): Target WSGI script '/var/www/cgi-bin/keystone/admin' cannot be loaded as Python module. 2015-07-21 18:52:45.069849 mod_wsgi (pid=14291): Exception occurred processing WSGI script '/var/www/cgi-bin/keystone/admin'. 2015-07-21 18:52:45.069881 Traceback (most recent call last): 2015-07-21 18:52:45.069919 File "/var/www/cgi-bin/keystone/admin", line 17, in <module> 2015-07-21 18:52:45.070021 from keystone.server import wsgi as wsgi_server 2015-07-21 18:52:45.070053 ImportError: No module named server

This is line 17: from keystone.server import wsgi as wsgi_server

edit retag flag offensive close merge delete

Comments

xxxxxxxxxx

ivarh gravatar imageivarh ( 2015-07-21 19:18:06 -0500 )edit

is this fresh install or upgrade ? If it's an upgrade, then some package are not upgraded properly.

According to usage, --type <service-type> is mandatory parameter so you need to use --type identity

Ranjit gravatar imageRanjit ( 2015-07-22 01:15:55 -0500 )edit

It is a fresh install. I tried a bunch of guesses as to the correct syntax, adding the identity. I may have gotten close, when I got the second error in Apache

ivarh gravatar imageivarh ( 2015-07-22 06:13:33 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-09-10 16:00:53 -0500

jjaquinta gravatar image

This error occurs when an older version of keystone has been installed. Specifically the keystone installed by apt-get in step 2 in the "To install and configure the Identity service components" section of "http://docs.openstack.org/kilo/install-guide/install/apt/content/keystone-install.html (Install and Configure)" in "Chapter 3: Add the identity service" guide, does not match the script downloaded in step 5 in the "To configure the Apache HTTP server" section.

This is caused by omitting the "To enable the OpenStack repository" section of "http://docs.openstack.org/kilo/install-guide/install/apt/content/ch_basic_environment.html#basics-packages (OpenStack packages)" in "http://docs.openstack.org/kilo/install-guide/install/apt/content/ch_basic_environment.html (Chapter 2: Basic environment)". Namely:

# apt-get install ubuntu-cloud-keyring
# echo "deb http://ubuntu-cloud.archive.canonical.com/ubuntu" \
  "trusty-updates/kilo main" > /etc/apt/sources.list.d/cloudarchive-kilo.list

If this repository is added, the correct version of keystone will be retrieved via apt-get.

edit flag offensive delete link more
0

answered 2015-07-22 22:42:31 -0500

ivarh gravatar image

I reinstalled and it worked... must have been me.

edit flag offensive delete link more

Comments

Hey ivarh, I've met the same problem as yours when installing identity service, getting "error: argument --type is required" all the time. Could you illustrate your solution in detail? Thanks!

Cheng Liu gravatar imageCheng Liu ( 2015-07-23 05:16:21 -0500 )edit

I have no clue what I did wrong. I rebuilt the machine from scratch and went through the install again and it just worked.

ivarh gravatar imageivarh ( 2015-07-23 16:42:19 -0500 )edit

@Cheng Liu: the documentation should read: $openstack service create --type identity --description "OpenStack Identity" keystone

langarita gravatar imagelangarita ( 2015-09-04 18:16:10 -0500 )edit

Hi, I am also facing the same problem. I had tried re-starting it several times but still my problem is not getting resolved.

himanshu05 gravatar imagehimanshu05 ( 2015-09-09 06:55:10 -0500 )edit

The simplest way to check is to do a wget localhost:5000 after you start apache. The installed module does not contained the server directory, which is up on github. There is a mismatch between the main script and the module.

jjaquinta gravatar imagejjaquinta ( 2015-09-10 13:16:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-07-21 12:16:01 -0500

Seen: 2,227 times

Last updated: Sep 10 '15