Ask Your Question
1

missing cpu model

asked 2015-07-21 00:51:06 -0600

ashu gravatar image
 Hi Team 

I'm running Openstack Icehouse on powerpc platfom and while running nova-compute I'm gacing following issues..

2015-07-20 09:52:50.981 7716 DEBUG nova.virt.libvirt.driver [-] Registering for connection events: <nova.virt.libvirt.driver.LibvirtDriver object at 0x1133bfd0> _get_new_connection /usr/lib/python2.7/site-packages/nova/virt/libvirt/driver.py:694
2015-07-20 09:52:50.992 7716 DEBUG nova.virt.libvirt.config [-] Generated XML ('<cpu>\n  <arch>ppc</arch>\n  <topology sockets="1" cores="4" threads="1"/>\n</cpu>\n',)  to_xml /usr/lib/python2.7/site-packages/nova/virt/libvirt/config.py:71
libvirt: CPU Driver error : XML error: Missing CPU model name
Traceback (most recent call last):
edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2016-03-01 16:41:36 -0600

mriedem gravatar image
edit flag offensive delete link more
0

answered 2015-07-22 05:42:54 -0600

ashu gravatar image
Hi  Team 

I made nova-compute with icehouse  work now on ppc platform.I made some changes in the code of nova-compute API and now I'm able to proceed successfully.

Thanks Team.
Abhishek Jain
edit flag offensive delete link more
0

answered 2015-07-22 02:33:38 -0600

Perhaps a stupid question, but is icehouse powerpc support actually good enough (or even existing), aren't there bugs wrt that CPU arch support ?

Maybe openstack is kind of arch agnostic, but maybe not... I ask because if you go have a look at the icehouse version of the doc you cite, there is no mention of powerpc...

Did you try with something more modern (juno, kilo) ? That would certainly allow to put the outdatedness question aside.

edit flag offensive delete link more
0

answered 2015-07-21 01:30:15 -0600

uts9 gravatar image

Can you check your /usr/share/libvirt/cpu_map.xml file? Also you can run #virsh cpu-models ppc64

edit flag offensive delete link more

Comments

virsh cpu-models ppc64 POWERPC_e6500 POWERPC_e5500 power8 power8e power7+ power7 power6 POWER8_v1.0 POWER7+_v2.1 POWER7_v2.3 POWER7_v2.1 POWER7

ashu gravatar imageashu ( 2015-07-21 02:01:48 -0600 )edit

also below is the output of different commands..

cat /proc/cpuinfo 

processor   : 0
cpu     : e5500
clock       : 1400.000000MHz
revision    : 2.1 (pvr 8024 1021)
bogomips    : 75.00

cat  /usr/share/libvirt/cpu_map.xml  | grep e5500  
    <model name='POWERPC_e5500'>

t

ashu gravatar imageashu ( 2015-07-21 02:04:16 -0600 )edit

but no cpu model is appearing in virsh capabilities | grep model command,,

virsh capabilities | grep model
    <secmodel>
      <model>none</model>
    </secmodel>
    <secmodel>
      <model>dac</model>
    </secmodel>
ashu gravatar imageashu ( 2015-07-21 06:40:06 -0600 )edit

Please share your hypervisorvirt_type details. Set cpu_mode=none in nova.conf and try.

Source

uts9 gravatar imageuts9 ( 2015-07-21 07:16:44 -0600 )edit

I configured virt_type=kvm and cpu_mode=none in /etc/nova/nova.conf but still the same result.

ashu gravatar imageashu ( 2015-07-21 07:38:07 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-07-21 00:51:06 -0600

Seen: 298 times

Last updated: Mar 01 '16