Instance Interface down

asked 2015-07-18 23:46:31 -0500

stacksam gravatar image

Hello,

One of the VMs on an hypervisor ( qemu-kvm ) lost one of its interfaces. The "nova interface-list" command show the port state as "Down" .

Looking for some help in troubleshooting and get the port "ACTIVE"

Thanks

edit retag flag offensive close merge delete

Comments

try rebooting to see if the network configuration gets pulled down via cloud-init.

omar-munoz gravatar imageomar-munoz ( 2015-07-21 15:37:20 -0500 )edit

I did reboot the instance but it won't see the interface eth1 and the cloud-init fails to setup the interface. I think there is something wrong at the Openvswitch/Neutron level. I can't seem to find what that is and how to enable the port.

stacksam gravatar imagestacksam ( 2015-07-21 16:56:01 -0500 )edit

can you do a neutron port-show on it and see if the admin state is down? please post the output of the port-show.

if it is down can you try something like neutron port-update 43c9ff00-07ce-4069-a734-4e6d5e795e6a --status ACTIVE

omar-munoz gravatar imageomar-munoz ( 2015-07-24 13:49:09 -0500 )edit

also try restarting the ovs agent.

omar-munoz gravatar imageomar-munoz ( 2015-07-24 13:52:45 -0500 )edit

Yes the port state is DOWN in port-show. I tried the "port-update" but it gave this error - Cannot update read-only attribute status

I restarted the OVS agent but no avail.

All other VMs on the same HV don't have this problem.

stacksam gravatar imagestacksam ( 2015-07-26 00:41:09 -0500 )edit