Mutlinode Devstack with two interfaces [closed]

asked 2015-07-16 09:28:05 -0500

anonymous user

Anonymous

Hi,

I've previously setup multi-node Openstack with RDO. I'm now trying to use devstack, which I'm finding more difficult.

With RDO I setup 1 controller + 1 compute. Both machines have 2 interfaces eth0, which is public, management, and is added to br-ex. And eth1 which is purely for private traffic between VMs. eth1 allows VLANs 10-20, and in RDO would get added to br-private.

I've tried to do the same thing with Devstack, but everytime it fails, or doesn't configure the system as expected (either eth1 gets added to br-ex, or br-ex isn't created etc).

Can anyone help me with the local.conf

Here is the relevant parts of mine:

[[local|localrc]]
FORCE=yes
HOST_NAME=$(hostname)
HOST_IP=192.168.100.10
HOST_IP_IFACE=eth0
PUBLIC_INTERFACE=eth0
VLAN_INTERFACE=eth1
FLAT_INTERFACE=eth1
disable_service n-net
disable_service n-cpu
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service q-meta
enable_service neutron
enable_service n-novnc
enable_service n-xvnc
enable_service n-crt
enable_service n-cauth
Q_AGENT=openvswitch
Q_ML2_PLUGIN_MECHANISM_DRIVERS=openvswitch
Q_ML2_PLUGIN_TYPE_DRIVERS=vlan,flat,local
Q_ML2_TENANT_NETWORK_TYPE=vlan
ENABLE_TENANT_TUNNELS=False
ENABLE_TENANT_VLANS=True
PHYSICAL_NETWORK=physnet1
ML2_VLAN_RANGES=physnet1:10:20
OVS_PHYSICAL_BRIDGE=br-eth1

Q_USE_PROVIDERNET_FOR_PUBLIC=True
OVS_BRIDGE_MAPPINGS=public:br-ex
OVS_ENABLE_TUNNELING=True

MULTI_HOST=True
edit retag flag offensive reopen merge delete

Closed for the following reason not a real question by rbowen
close date 2017-02-14 12:51:11.819347

Comments

When you say "it fails, or doesn't configure the system as expected", you need to provide additional details, and, where possible, log file output, to aid troubleshooting.

rbowen gravatar imagerbowen ( 2016-08-12 15:48:03 -0500 )edit

Closing, due to lack of user feedback.

rbowen gravatar imagerbowen ( 2017-02-14 12:51:01 -0500 )edit