Setup CEPH as a backend for Glance

asked 2015-07-15 22:21:48 -0600

DEX gravatar image

Attempted Configurations: Ubuntu 14.04, 14.04.2, 15.04 Openstack: Juno, Kilo CEPH: Firefly, Giant, CEPH

Overview When setting 'default_store = rbd' in '/etc/glance/glance-api.conf' the 'glance-api' service will crash. I have tried configuring Glance with and without authentication and can verify the 'images' pool is available and the CEPH Cluster is healthy.

I have been unable to get glance to work with CEPH with any of the above combinations of Ubuntu, Openstack, and CEPH. I have deployed a each of these CEPH versions with and without CEPHx authentication but continue to see glance-api service crash moments after starting.

Any help or suggestions are appreciated, any requests for particular log files can be provided.

Thank you in advanced

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted

answered 2015-07-22 19:55:14 -0600

Acrobat622 gravatar image

Hi, have you checked the fields under [glance_store] section regarding RBD store backends that all fields were set properly?

In addition, there is a value under [glance_store] named "stores", please set this value to include the rbd option

edit flag offensive delete link more

answered 2015-07-23 00:14:02 -0600

bkopilov gravatar image

Hi ,

Here are the configurations for glance :

    "glance_store": {
        "rbd_store_user": "USER",
        "rbd_store_pool": "POOL_NAME",
        "show_image_direct_url": "True",
        "rbd_store_ceph_conf": "/etc/ceph/ceph.conf",
        "rbd_store_chunk_size": "8",
        "stores": ",,"
    "DEFAULT": {
        "default_store": "rbd"

Thanks, Benny

edit flag offensive delete link more

answered 2015-07-23 07:11:52 -0600

Ram.Meena gravatar image

updated 2015-07-23 07:12:36 -0600


As written by Benny, you need to write below settings in glance api configuration file:

default_store = rbd
stores =
rbd_store_pool = images
rbd_store_user = glance
rbd_store_ceph_conf = /etc/ceph/ceph.conf
rbd_store_chunk_size = 8

You should make sure to setup appropriate authentication with ceph cluster.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2015-07-15 22:21:48 -0600

Seen: 1,162 times

Last updated: Jul 23 '15