Problems running ./stack.sh (g-api and g-reg api is not running) [closed]

asked 2015-07-15 07:04:23 -0500

nats gravatar image

updated 2015-07-16 11:36:40 -0500

Hi there,

I've already ran ./stack multiple times before, and it always ran with success (faced some minor erros that fixed). Never faced this error and didn't find any solution to it:

2015-07-15 11:49:20.155 | + echo 'Error: Service g-reg is not running'
2015-07-15 11:49:20.155 | Error: Service g-reg is not running
2015-07-15 11:49:20.155 | + '[' -n '/opt/stack/status/stack/g-api.failure
2015-07-15 11:49:20.155 | /opt/stack/status/stack/g-reg.failure' ']'
2015-07-15 11:49:20.156 | + die 1406 'More details about the above errors can be found with screen, with ./rejoin-stack.sh'
2015-07-15 11:49:20.156 | + local exitcode=0
2015-07-15 11:49:20.156 | [Call Trace]
2015-07-15 11:49:20.156 | ./stack.sh:1374:service_check
2015-07-15 11:49:20.156 | /home/user/devstack/functions-common:1406:die
2015-07-15 11:49:20.161 | [ERROR] /home/user/devstack/functions-common:1406 More details about the above errors can be found with screen, with ./rejoin-stack.sh
2015-07-15 11:49:21.213 | Error on exit
2015-07-15 11:49:21.604 | Another app is currently holding the xtables lock. Perhaps you want to use the -w option?
2015-07-15 11:49:21.605 | Another app is currently holding the xtables lock. Perhaps you want to use the -w option?

Edited: Well i kept running into that error, decided to delete all the stack files (./clean.sh and /opt/stack) and clone devstack again. After that i ran stack.sh again and got another in a earlier stage ( virtualenv /opt/stack/requirements/.venv ; then it says virtualenv command not found, exit_trap,...:

2015-07-15 18:07:13.873 | Requirement already up-to-date: virtualenv in /usr/local/lib/python2.7/dist-packages
2015-07-15 18:07:13.933 | ++ local 'test_req=-U virtualenv/test-requirements.txt'
2015-07-15 18:07:13.934 | ++ [[ -e -U virtualenv/test-requirements.txt ]]
2015-07-15 18:07:13.934 | + install_infra
2015-07-15 18:07:13.934 | + local PIP_VIRTUAL_ENV=/opt/stack/requirements/.venv
2015-07-15 18:07:13.934 | + git_clone git://git.openstack.org/openstack/requirements.git /opt/stack/requirements master
2015-07-15 18:07:13.934 | + local git_remote=git://git.openstack.org/openstack/requirements.git
2015-07-15 18:07:13.934 | + local git_dest=/opt/stack/requirements
2015-07-15 18:07:13.934 | + local git_ref=master
2015-07-15 18:07:13.935 | ++ pwd
2015-07-15 18:07:13.935 | + local orig_dir=/home/user/devstack
2015-07-15 18:07:13.935 | + local git_clone_flags=
2015-07-15 18:07:13.936 | ++ trueorfalse False RECLONE
2015-07-15 18:07:13.940 | + RECLONE=True
2015-07-15 18:07:13.940 | + [[ 0 -gt 0 ]]
2015-07-15 18:07:13.940 | + [[ False = \T\r\u\e ]]
2015-07-15 18:07:13.941 | + echo master
2015-07-15 18:07:13.942 | + egrep -q '^refs'
2015-07-15 18:07:13.943 | + [[ ! -d /opt/stack/requirements ]]
2015-07-15 18:07:13.943 | + [[ False = \T\r\u\e ]]
2015-07-15 18:07:13.943 | + git_timed clone git://git.openstack.org/openstack/requirements.git /opt/stack/requirements
2015-07-15 18:07:13.943 | + local count=0
2015-07-15 18:07:13.943 | + local timeout=0
2015-07-15 18:07:13.943 | + [[ -n 0 ]]
2015-07-15 18:07:13.943 ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by nats
close date 2015-07-23 11:43:59.828456