Ask Your Question
0

Glance image create ceph problem [closed]

asked 2015-07-14 22:27:23 -0500

Acrobat622 gravatar image

updated 2015-07-15 00:56:19 -0500

Hi all

I have deployed OpenStack kilo following the guide. Right now there is only one Ubntu 14.04 VM which is the controller. I have another 4 VMs running a Ceph (v0.94.2) cluster. The controller is not running any ceph service. I want to use the Ceph cluster as the storage backend for glance. I created the keyring as stated in http://docs.openstack.org/developer/glance/configuring.html (http://docs.openstack.org/developer/g...) and modified my glance-api.conf accordingly. However, when I try to upload an image, the progress bar stuck at around 35% forever. I check the glance-api.log it shows:

WARNING glance_store._drivers.rbd [req-5c20a2c3-7cdc-4b25-802e-7aeca07f96b4 188e1b19cd2649a686e0d8faa0b1f1ff c29a18719e8842a7bad13ec70ddf3fe0 - - -] since image size is zero we will be doing resize-before-write for each chunk which will be considerably slower than normal

I check the images pool in ceph and there is nothing. The image can never be uploaded. Can someone help me to resolve this problem? Any help is much appreciated.

Here are my logs and config files: glance-api.log: http://pastebin.com/embed_js.php?i=scJQvwcy (http://pastebin.com/embed_js.php?i=sc...) glance-api.conf: http://pastebin.com/embed_js.php?i=PYEQe9s4 (http://pastebin.com/embed_js.php?i=PY...) ceph.conf: http://pastebin.com/embed_js.php?i=DgmAjx3F (http://pastebin.com/embed_js.php?i=Dg...)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Acrobat622
close date 2015-07-22 04:09:31.306163

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-07-15 08:33:50 -0500

updated 2015-07-15 08:40:54 -0500

Hi, try adding this lines at RBD store options and restart glance-api

-------RBD Store Options------
stores=rbd 
show_image_direct_url=True

The option default_store now goes in DEAFAULT section

[DEFAULT]
default_store = rbd

Ensure that your glance user key has rwx permissions in images pool and that ceph.conf has 644 permissions in openstack nodes

edit flag offensive delete link more

Comments

Hi Eduardo thanks for your reply

I have changed the lines as you suggested in glance-api.conf and the permission of ceph.conf in the openstack node and restarted all the services, but the problem persists and the log file reflects the same problem.

Acrobat622 gravatar imageAcrobat622 ( 2015-07-15 20:17:13 -0500 )edit

can somebody help me out to resolve this problwem

nizam_m037 gravatar imagenizam_m037 ( 2017-07-17 05:09:01 -0500 )edit
0

answered 2015-07-22 04:07:59 -0500

Acrobat622 gravatar image

updated 2015-07-22 04:09:01 -0500

This problem is solved after I add in the following lines in ceph.conf and rebooted all ceph nodes:

[client]

rbd cache = true
rbd cache writethrough until flush = true
admin socket = /var/run/ceph/guests/$cluster-$type.$id.$pid.$cctid.asok
log file = /var/log/qemu/qemu-guest-$pid.log
rbd concurrent management ops = 20
edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-07-14 21:33:59 -0500

Seen: 1,877 times

Last updated: Jul 22 '15