Package conflict with python-oslo-concurrency and python-oslo.concurrency

asked 2015-07-14 03:54:52 -0500

updated 2015-07-15 11:17:46 -0500

zaneb gravatar image

We tried to install python-horizon and python-heat from git repo

Here we are facing an issue with the conflicts b/n packages python-oslo.concurrency and python-oslo-concurrency while installing python-horizon and python-heat.

If we try to install python-horizon before python-heat then we are getting below error as python-heat requires python-oslo-concurrency

trying to overwrite '/usr/bin/python2-lockutils-wrapper', which is also in package python-oslo-concurrency 1.8.0-0ubuntu1~cloud0 Errors were encountered while processing: /var/cache/apt/archives/python-oslo.concurrency_1.8.0-1_all.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

In the other case if we try to install python-heat before python-horizon then we are getting conflicts b/n with the same two packages.

This is because python-horizon requires a dependency django-pycss package which in turn depends on oslo.concurrency.

edit retag flag offensive close merge delete