Ask Your Question
0

Installing DevStack Kilo with python-keystoneclient

asked 2015-07-13 12:05:34 -0500

zok_8 gravatar image

updated 2015-07-14 08:23:54 -0500

Hi, I'm trying to install DevStack (version:Kilo) on a Ubuntu 14.04 server , and putting the line LIBS_FROM_GIT=python-keystoneclient,django_openstack_auth into the stackrc file

but when I run stack.sh, the installation terminates with the following:

  • cd /opt/stack/requirements
  • ./.venv/bin/python update.py /opt/stack/python-keystoneclient Version change for: pbr, oslo.config, oslo.i18n, oslo.serialization, oslo.utils, prettytable, requests, stevedore Updated /opt/stack/python-keystoneclient/requirements.txt: pbr<2.0,>=0.11 -> pbr>=0.6,!=0.7,<1.0 oslo.config>=1.11.0 # Apache-2 -> oslo.config>=1.9.3,<1.10.0 # Apache-2.0 oslo.i18n>=1.5.0 # Apache-2.0 -> oslo.i18n>=1.5.0,<1.6.0 # Apache-2.0 oslo.serialization>=1.4.0 # Ap -> oslo.serialization>=1.4.0,<1.5.0 # Apache-2.0 oslo.utils>=1.6.0 # Apache-2.0 -> oslo.utils>=1.4.0,<1.5.0 # Apache-2.0 PrettyTable<0.8,>=0.7 -> PrettyTable>=0.7,<0.8 requests>=2.5.2 -> requests>=2.2.0,!=2.4.0 stevedore>=1.5.0 # Apache-2.0 -> stevedore>=1.3.0,<1.4.0 # Apache-2.0 Traceback (most recent call last): File "update.py", line 270, in <module> main(options, args) File "update.py", line 255, in main _copy_requires(options.suffix, options.softupdate, args[0]) File "update.py", line 230, in _copy_requires suffix, softupdate) File "update.py", line 164, in _sync_requirements_file old_pip = _package_name(old_require) File "update.py", line 101, in _package_name name = pkg_resources.Requirement.parse(pip_line).project_name File "/opt/stack/requirements/.venv/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2986, in parse reqs = list(parse_requirements(s)) File "/opt/stack/requirements/.venv/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2930, in parse_requirements "version spec") File "/opt/stack/requirements/.venv/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2906, in scan_list raise RequirementParseError(msg, line, "at", line[p:]) pkg_resources.RequirementParseError: Expected ',' or end-of-list in mock>=1.1;python_version!='2.6' at ;python_version!='2.6'
  • exit_trap
  • local r=1 ++ jobs -p
  • jobs=
  • [[ -n '' ]]
  • kill_spinner
  • '[' '!' -z '' ']'
  • [[ 1 -ne 0 ]]
  • echo 'Error on exit' Error on exit
  • [[ -z /opt/stack/logs ]]
  • /home/s/git/devstack/tools/worlddump.py -d /opt/stack/logs World dumping... see /opt/stack/logs/worlddump-2015-07-12-214827.txt for details
  • exit 1

I need the python-keystone-client for my installation, so, is there any way to fix this? Not sure what other information I might need to post here so the error can be determined better.

Edited for correcting the error message.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-08-06 08:08:05 -0500

zok_8 gravatar image

Solved it by setting the branch from where to get python-keystoneclient and django_openstack_auth from master to stable/kilo in stackrc.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2015-07-13 12:05:34 -0500

Seen: 672 times

Last updated: Jul 14 '15