Ask Your Question
0

Keystone Identity service: Unable to establish connection

asked 2015-07-10 17:16:32 -0500

ubchaudhry gravatar image

Can someone please help. I've been stuck on this for quite some time now and its frustrating me alot. I cant move forward. keystone tenant-create --name admin --description "Admin Tenant"

Unable to establish connection to http://controller:35357/v2.0/tenants

Any advice? Every thing else uptill here is exacty as it has been described in the OFFICIAL UBUNTU NEUTRON MANUAL.

Something that might help:

ps -fe | grep keystone

keystone 5075 1 0 time ? /usr/bin/python /usr/bin/keystone-all

root 5080 2467 0 time tty grep --color=auto keystone

ss -tlnp | grep 35357

shows nothing

logging is not active so i cant share the log file

The install guide that I have followed is

http://docs.openstack.org/juno/install-guide/install/apt/content/ (http://docs.openstack.org/juno/instal...)

I have followed it exactly on virual box. Everything untill this command was running perfect. I am following the neutron architecture mentioned in the guide.

Any/All help will be deepy appreciated.

In case the only solution turns out to be reinstalling keystone, please advise how should I roll back the already installed settings. Thank you.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-08-19 03:31:08 -0500

jianzj gravatar image

Hi, since there is no port "35357" open in your environment as your description "ss -tlnp | grep 35357", so you should not establish connection to url "http://controller:35357/v2.0/tenants".

Actually , in Keystone Service , there are two ports listened : 5000, for public and internal request; 35357, for admin request.

When you run Keystone Service, it will be listened.

I am not sure what is happened in your environment, maybe you could have a try :

1) netstat -an | grep 5000 , to see if this port is there ;

2) kill the process "keystone-all" using "kill -9 $process-id";

3) Make sure your configuration file is into suitable position "/etc/keystone/keystone.conf", with wsgi paste file "/etc/keystone/keystone-paste.ini" 3) Rerun this command, "keystone-all --config-dir /etc/keystone" . This command is running into the window, and if any errors happened, we could go through what happened.

Hope it work for you.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-07-10 17:15:43 -0500

Seen: 228 times

Last updated: Aug 19 '15