How to enable resume guest state on boot?

asked 2013-11-28 01:57:35 -0500

updated 2013-11-29 17:06:58 -0500

smaffulli gravatar image

I have all-in-one Havana installation (centOS, KVM). After rebooting host instances appears to be stopped:

Status  Task  Power State
Shutoff  None  Shutdown

In /etc/nova/nova.conf:

resume_guests_state_on_host_boot = True

/var/lib/nova/compute.log during reboot:

2013-11-28 12:21:57.923 2735 INFO nova.compute.manager [-] Lifecycle event 1 on VM 70aba369-c7a0-43b4-8fde-39f141257c44
2013-11-28 12:21:58.211 2735 WARNING nova.compute.manager [-] [instance: 70aba369-c7a0-43b4-8fde-39f141257c44] Instance shutdown by itself. Calling the stop API.
2013-11-28 12:21:58.439 2735 INFO nova.openstack.common.rpc.impl_qpid [req-35588b9d-ed71-46c6-8a44-55ca28f24bea None None] Connected to AMQP server on 192.168.250.20:5672
2013-11-28 12:21:58.731 2735 INFO nova.virt.libvirt.driver [-] [instance: 70aba369-c7a0-43b4-8fde-39f141257c44] Instance destroyed successfully.
2013-11-28 12:22:00.491 2735 INFO nova.openstack.common.service [-] Caught SIGTERM, exiting
2013-11-28 12:24:13.686 2764 INFO nova.openstack.common.periodic_task [-] Skipping periodic task _periodic_update_dns because its interval is negative
2013-11-28 12:24:13.820 2764 INFO nova.virt.driver [-] Loading compute driver 'libvirt.LibvirtDriver'
2013-11-28 12:24:14.134 2764 INFO nova.openstack.common.rpc.impl_qpid [req-b54ca437-bbe0-47f1-b41a-d162e0477620 None None] Connected to AMQP server on 192.168.250.20:5672
2013-11-28 12:24:14.154 2764 INFO nova.openstack.common.rpc.impl_qpid [req-b54ca437-bbe0-47f1-b41a-d162e0477620 None None] Connected to AMQP server on 192.168.250.20:5672
2013-11-28 12:24:24.172 2764 WARNING nova.conductor.api [req-b54ca437-bbe0-47f1-b41a-d162e0477620 None None] Timed out waiting for nova-conductor. Is it running? Or did this service start before nova-conductor?
2013-11-28 12:24:24.223 2764 AUDIT nova.service [-] Starting compute node (version 2013.2-2.el6)
2013-11-28 12:24:25.097 2764 AUDIT nova.compute.resource_tracker [-] Auditing locally available compute resources
2013-11-28 12:24:25.270 2764 AUDIT nova.compute.resource_tracker [-] Free ram (MB): 5334
2013-11-28 12:24:25.270 2764 AUDIT nova.compute.resource_tracker [-] Free disk (GB): 275
2013-11-28 12:24:25.270 2764 AUDIT nova.compute.resource_tracker [-] Free VCPUS: 3
2013-11-28 12:24:25.443 2764 INFO nova.compute.resource_tracker [-] Compute_service record updated for tn0.stu.neva.ru:tn0.stu.neva.ru
2013-11-28 12:24:25.483 2764 INFO nova.openstack.common.rpc.impl_qpid [-] Connected to AMQP server on 192.168.250.20:5672
2013-11-28 12:24:35.517 2764 INFO nova.openstack.common.rpc.impl_qpid [req-190f2888-0f34-40db-a4c7-b829baa65e70 None None] Connected to AMQP server on 192.168.250.20:5672
2013-11-28 12:24:35.592 2764 AUDIT nova.compute.resource_tracker [req-190f2888-0f34-40db-a4c7-b829baa65e70 None None] Auditing locally available compute resources
2013-11-28 12:24:35.758 2764 AUDIT nova.compute.resource_tracker [req-190f2888-0f34-40db-a4c7-b829baa65e70 None None] Free ram (MB): 5334
2013-11-28 12:24:35.758 2764 AUDIT nova.compute.resource_tracker [req-190f2888-0f34-40db-a4c7-b829baa65e70 None None] Free disk (GB): 275
2013-11-28 12:24:35.759 2764 AUDIT nova.compute.resource_tracker [req-190f2888-0f34-40db-a4c7-b829baa65e70 None None] Free VCPUS: 3
2013-11-28 12:24:35.872 2764 INFO nova.compute.resource_tracker [req-190f2888-0f34-40db-a4c7-b829baa65e70 None None] Compute_service record updated for tn0.stu.neva.ru:tn0.stu.neva.ru
2013-11-28 12:24:36.208 2764 WARNING nova.compute.manager [req-190f2888-0f34-40db-a4c7-b829baa65e70 None None] [instance: 70aba369-c7a0-43b4-8fde-39f141257c44] Instance is not stopped. Calling the stop API.
2013-11-28 12:24 ...
(more)
edit retag flag offensive close delete

Comments

I hope you have added the above "resume_guests_state_on_host_boot = True" parameter in your compute nodes nova.conf, not in your controller node. Am I right?

Ashokb ( 2013-11-28 04:20:28 -0500 )edit

No. I'm working with all-in-one installation. Sorry for saying "compute node"..

laboshinl ( 2013-11-28 04:30:58 -0500 )edit