Ask Your Question
0

Neutron Network node not Routing

asked 2015-07-09 09:37:54 -0600

JD Hallen gravatar image

updated 2015-07-10 12:58:27 -0600

Pulling my hair out on this one.... I can't get my Neutron network node to do a simple route of a packet to my controller node! I'm sure its something stupid, but I can't see it I guess. /proc/sys/net/ipv4/ip_forward has '1' as its content. /etc/sysctl.conf looks like this:

net.ipv4.conf.all.rp_filter=0
net.ipv4.conf.default.rp_filter=0
net.ipv4.ip_forward=1

I can get to all my instances on my compute nodes, so I know the bridging/tunneling is working. All three networks (External on br-ex, Tunnel on eth2, Management on eth0, eth1 assigned to br-ex) show up in my 'ip a' output. I can ping the Compute and Controller nodes just fine from the Network node, but outside connections coming in on the External network stop at the Network node.

What am I doing wrong?? Thanks for your time! JD

UPDATE1:

# ovs-vsctl show
3ec0fc70-90ce-4e89-818f-5fdab99bf08a
    Bridge br-int
        fail_mode: secure
        Port br-int
            Interface br-int
                type: internal
        Port "tap221f3067-b6"
            tag: 3
            Interface "tap221f3067-b6"
                type: internal
        Port int-br-ex
            Interface int-br-ex
                type: patch
                options: {peer=phy-br-ex}
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "tap114ed438-14"
            tag: 1
            Interface "tap114ed438-14"
                type: internal
        Port "tapac8c15d2-cc"
            tag: 2
            Interface "tapac8c15d2-cc"
                type: internal
        Port "qr-dec6f704-48"
            tag: 3
            Interface "qr-dec6f704-48"
                type: internal
    Bridge br-ex
        Port phy-br-ex
            Interface phy-br-ex
                type: patch
                options: {peer=int-br-ex}
        Port "qg-710689ae-67"
            Interface "qg-710689ae-67"
                type: internal
        Port br-ex
            Interface br-ex
                type: internal
        Port "eth1"
            Interface "eth1"
    Bridge br-tun
        fail_mode: secure
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
        Port "gre-0a000119"
            Interface "gre-0a000119"
                type: gre
                options: {df_default="true", in_key=flow, local_ip="10.0.1.28", out_key=flow, remote_ip="10.0.1.25"}
        Port br-tun
            Interface br-tun
                type: internal
    ovs_version: "2.0.2"


# ifconfig
br-ex     Link encap:Ethernet  HWaddr 00:1e:90:13:9a:f6
          inet addr:10.147.29.28  Bcast:10.147.29.255  Mask:255.255.255.0
          inet6 addr: fe80::b803:34ff:fe88:d5c3/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:10273 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5682 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1114956 (1.1 MB)  TX bytes:1168138 (1.1 MB)

br-int    Link encap:Ethernet  HWaddr c2:81:7e:1a:7f:4f
          inet6 addr: fe80::8401:81ff:fe90:8376/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:68 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5148 (5.1 KB)  TX bytes:648 (648.0 B)

br-tun    Link encap:Ethernet  HWaddr 0e:44:0c:98:9f:49
          inet6 addr: fe80::dc18:d2ff:fec6:2d2c/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX ...
(more)
edit retag flag offensive close merge delete

Comments

Say qdhcp-xxxxxx is your qdhcp namespace:-

ip netns exec qdhcp-xxxxxx ping IP-of-br-ex ?
ip netns exec qdhcp-xxxxxx ping IP-of-external-router ?
dbaxps gravatar imagedbaxps ( 2015-07-09 10:35:12 -0600 )edit

Say qroueter-xxxxxx is your qrouter namespace:-

ip netns exec qdhcp-xxxxxx route -n ?
ip netns exec qrouter-xxxxxx ifconfig ?
dbaxps gravatar imagedbaxps ( 2015-07-09 10:37:39 -0600 )edit

Please, post ovs-vsctl show && ifconfig on Network node as UPDATE 1 to your question.

dbaxps gravatar imagedbaxps ( 2015-07-09 10:39:01 -0600 )edit

dbaxps: which one?

# ip netns
qdhcp-a29141d5-585d-463f-932b-9860f90d6b14
qdhcp-e5e9dcd0-a93e-4f18-8217-0bc89a650a39
qdhcp-71932895-a158-4ca4-89ca-03305f918f14
qrouter-c939264f-e3ee-45d5-a885-11ad94e04c12
JD Hallen gravatar imageJD Hallen ( 2015-07-09 12:59:32 -0600 )edit

a29141d5-585d-463f-932b-9860f90d6b14 should be private net id for your VM
Those on which matches condition mentioned above

dbaxps gravatar imagedbaxps ( 2015-07-09 13:07:26 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-07-14 16:17:28 -0600

JD Hallen gravatar image

Problem somehow corrected itself and everything routes correctly now....which is odd since I didn't change anything. Maybe someone hacked into my cloud and fixed it so they can correctly do their nefarious deeds ;) JD

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-07-09 09:37:54 -0600

Seen: 158 times

Last updated: Jul 14 '15