Ask Your Question
1

Connection to instance dies on 'large' packets in Juno

asked 2015-07-09 09:26:39 -0500

JD Hallen gravatar image

updated 2015-07-09 09:28:36 -0500

Juno installed according to the manual instructions w/Neutron networking. Instances come up fine with no errors, gets all its DHCP-assigned IP addresses, Floating IP assigned -- all with no errors. I connect to any instance via SSH and as long as the output from the instance takes no more than one or two packets, the connection is fine. If I try to do something like 'ls -al /var/log', it hangs and the session times out. I can reconnect just fine, there are no errors in either the instance logs, nor in the Neutron logs that I can see. I've tried this on four different instances (CentOS 7, Ubuntu 14.04.2, Ubuntu 15.04, and F5 BIG-IP v11.6.0) and all behave the same way. I also tried it on the default Cirros image, but can't reproduce the problem there...not sure if the output is long enough to trigger the issue or not.

Not sure, but this might tie into my other current networking issue where I can't get any HTTPS connection to one of my instance. (its question # 69288 -- I would just post the link, but since I have no 'karma' on this site, I'm not allowed.)

Thanks for your help! JD

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-07-14 16:13:38 -0500

JD Hallen gravatar image

Ok, figured out the issue and posting here in case someone else runs into this issue.

I always figured it had something to do with the networking, since I could always get connections, just not 'large' outputs.

My OpenStack Juno cloud has the "default" three nodes: Network, Compute, Controller. I went with the default GRE Tunnel between the Network and the Compute nodes. GRE Tunnels take out a little under 50 bytes of overhead away from the MTU. When I looked at my instances' interface settings, I noticed that it was still set to 1500! For some reason it was not adjusting the end-to-end MTU like I thought it would. Once I brought it down to 1450, everything worked like a champ. I thought linux would auto-adjust MTU, but for my cloud, it did not. All my instances have been adjusted and everything is working correctly now.

JD

edit flag offensive delete link more
0

answered 2015-07-15 02:59:11 -0500

updated 2015-07-15 02:59:36 -0500

To check if Path MTU Discovery is disabled:

sysctl net.ipv4.ip_no_pmtu_disc
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-07-09 09:26:39 -0500

Seen: 163 times

Last updated: Jul 15 '15