Ask Your Question

Cannot login Horizon Dashboard [closed]

asked 2013-11-27 10:20:09 -0500

gpanda gravatar image

I installed devstack in my vm couple of weeks before, I once was able to login the dashboard, but now I cannot, it keeps saying "An error occurred authenticating. Please try again later.", I use "admin" and the password I set in localrc(ADMIN_PASSWORD) to login, can anybody give me some hints? I cannot remeber if I changed the user name over "admin" thanks in advance!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by dheeru
close date 2013-12-02 23:15:59.109709


check whether keystone service is working.

dheeru gravatar imagedheeru ( 2013-11-27 10:50:22 -0500 )edit

Is issue resolved ? Please do let me know.

dheeru gravatar imagedheeru ( 2013-12-02 12:45:51 -0500 )edit

3 answers

Sort by ยป oldest newest most voted

answered 2013-11-27 11:46:32 -0500

jpichon gravatar image

Have a look in the httpd/apache2 logs as well, they should contain more information about the failure.

Note that devstack sets up a development environment that isn't meant to persist after reboot, if you rebooted the machine you'll have to run ./ again.

edit flag offensive delete link more


Thanks jpichon! ./ solve my problem. BTW, this is actually another question(I'm a newbie to stack :-\) ./ must to be done after each reboot? which takes me 537 seconds this time. Is there any light alternative way to get back all the services, Is ./ possible? Thanks again.

gpanda gravatar imagegpanda ( 2013-11-28 03:39:15 -0500 )edit

Yes, ./ should help too, give it a shot :)

jpichon gravatar imagejpichon ( 2013-12-02 06:06:03 -0500 )edit

answered 2013-11-27 11:12:33 -0500

dheeru gravatar image

updated 2013-11-27 11:12:48 -0500

keystone may be down. Check 'service keystone status' and then 'service keystone restart'. It should work.

edit flag offensive delete link more


In my devstack env, none of openstack' own services(nova/keystone/glance...) is registered in /etc/init.d, so I cannot use 'service' to check. I check with ps ef | grep xxx. after a normal restart of my vm, all of them are inactive, can wake them up

gpanda gravatar imagegpanda ( 2013-12-02 20:01:32 -0500 )edit

answered 2013-12-02 19:47:53 -0500

gpanda gravatar image

updated 2013-12-02 21:14:28 -0500

Yes, ./ also works, which is just what I want. Thanks, jpichon!

edit flag offensive delete link more


Thats cool. I will close you request. Hope it is ok.

dheeru gravatar imagedheeru ( 2013-12-02 22:35:53 -0500 )edit

thanks dheeru, my karma is not enough to let me close my question:)

gpanda gravatar imagegpanda ( 2013-12-02 22:45:38 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2013-11-27 10:20:09 -0500

Seen: 5,083 times

Last updated: Dec 02 '13