Ask Your Question
0

cinder-manage db sync backend Import Error

asked 2013-11-27 03:31:27 -0500

Nazmil gravatar image

Hi all,

im trying to install openstack folsom based from below guide:

https://openstack-folsom-install-guide.readthedocs.org/en/latest/#basic-configuration

im at the cinder steps, whenever i execute "cinder-manage db sync"

below exception appear.

root@computenode:/etc/init.d# cinder-manage db sync 2013-11-27 17:14:53 18789 DEBUG cinder.utils [-] backend <module '="" 'cinder.db.sqlalchemy.migration'="" cinder="" db="" dist-packages="" from="" lib="" migration.pyc'="" python2.7="" sqlalchemy="" usr=""> __get_backend /usr/lib/python2.7/dist-packages/cinder/utils.py:481 Command failed, please check log for more info 2013-11-27 17:14:53 18789 CRITICAL cinder [-] No module named qpid.messaging 2013-11-27 17:14:53 18789 TRACE cinder Traceback (most recent call last): 2013-11-27 17:14:53 18789 TRACE cinder File "/usr/bin/cinder-manage", line 757, in <module> 2013-11-27 17:14:53 18789 TRACE cinder main() 2013-11-27 17:14:53 18789 TRACE cinder File "/usr/bin/cinder-manage", line 745, in main 2013-11-27 17:14:53 18789 TRACE cinder rpc.cleanup() 2013-11-27 17:14:53 18789 TRACE cinder File "/usr/lib/python2.7/dist-packages/cinder/openstack/common/rpc/__init__.py", line 203, in cleanup 2013-11-27 17:14:53 18789 TRACE cinder return _get_impl().cleanup() 2013-11-27 17:14:53 18789 TRACE cinder File "/usr/lib/python2.7/dist-packages/cinder/openstack/common/rpc/__init__.py", line 269, in _get_impl 2013-11-27 17:14:53 18789 TRACE cinder _RPCIMPL = importutils.import_module(impl) 2013-11-27 17:14:53 18789 TRACE cinder File "/usr/lib/python2.7/dist-packages/cinder/openstack/common/importutils.py", line 58, in import_module 2013-11-27 17:14:53 18789 TRACE cinder __import__(import_str) 2013-11-27 17:14:53 18789 TRACE cinder File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/impl_qpid.py", line 26, in <module> 2013-11-27 17:14:53 18789 TRACE cinder import qpid.messaging 2013-11-27 17:14:53 18789 TRACE cinder ImportError: No module named qpid.messaging 2013-11-27 17:14:53 18789 TRACE cinder</module></module></module>

any hints or guide are much appreciated.

below are some configuration files you might want to know

/etc/cinder/cinder.conf

rootwrap_config=/etc/cinder/rootwrap.conf sql_connection = mysql://cinderUser:cinderPass@16.189.82.181/cinder api_paste_confg = /etc/cinder/api-paste.ini iscsi_helper=ietadm volume_name_template = volume-%s volume_group = cinder-volumes verbose = True auth_strategy = keystone rpc_backend = nova.openstack.common.rpc.impl_qpid #osapi_volume_listen_port=5900 root@computenode:/var/log/cinder#

root@computenode:/var/log/cinder# cat /etc/cinder/api-paste.ini #############

Openstack

#############

[composite:osapi_volume] use = call:cinder.api.openstack.urlmap:urlmap_factory /: osvolumeversions /v1: openstack_volume_api_v1

[composite:openstack_volume_api_v1] use = call:cinder.api.auth:pipeline_factory noauth = faultwrap sizelimit noauth osapi_volume_app_v1 keystone = faultwrap sizelimit authtoken keystonecontext osapi_volume_app_v1 keystone_nolimit = faultwrap sizelimit authtoken keystonecontext osapi_volume_app_v1

[filter:faultwrap] paste.filter_factory = cinder.api.openstack:FaultWrapper.factory

[filter:noauth] paste.filter_factory = cinder.api.openstack.auth:NoAuthMiddleware.factory

[filter:sizelimit] paste.filter_factory = cinder.api.sizelimit:RequestBodySizeLimiter.factory

[app:osapi_volume_app_v1] paste.app_factory = cinder.api.openstack.volume:APIRouter.factory

[pipeline:osvolumeversions] pipeline = faultwrap osvolumeversionapp

[app:osvolumeversionapp] paste.app_factory = cinder.api.openstack.volume.versions:Versions.factory

##########

Shared

##########

[filter:keystonecontext] paste.filter_factory = cinder.api.auth:CinderKeystoneContext.factory

[filter:authtoken] paste.filter_factory = keystone.middleware.auth_token:filter_factory service_protocol = http service_host = 16.189.82.181 ... (more)

edit retag flag offensive close merge delete

Comments

Do you have red-hat installation ? Which component you are using for messaging ? Is it qpid or rabbitmq ? It make sense to install the appropriate package for the same.

dheeru gravatar imagedheeru ( 2013-11-27 23:28:26 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2013-11-28 10:08:38 -0500

dheeru gravatar image

updated 2013-11-28 10:12:16 -0500

Your cinder.conf says the following.

auth_strategy = keystone 
rpc_backend = nova.openstack.common.rpc.impl_qpid 

This expects you to have installed qpid module. Right now it is failing to import this qpid. It means that you have not installed qpid.

Since you are using rabbitMQ, please do the following

1.  Comment above line(rpc_backend)
2.  Change you cinder.conf to following

rpc_backend = cinder.openstack.common.rpc.impl_kombu
rabbit_host = controller
rabbit_port = 5672
rabbit_userid = guest
rabbit_password = RABBIT_PASS<------------specify the right password
edit flag offensive delete link more

Comments

Hope your issue is resolved. Please update. Please do let me know if you need any help.

dheeru gravatar imagedheeru ( 2013-12-02 04:08:46 -0500 )edit
0

answered 2013-11-27 17:03:07 -0500

fifieldt gravatar image

Folsom is no longer supported. Please update to a later version.

You can find the Ubuntu installation guide for the Havana release here: http://docs.openstack.org/havana/install-guide/install/apt/content/

In response to your specific question - there is something wrong with your configuration that is making it refer to qpid, instead of rabbitmq (the ubuntu default) for messaging. You'll need to find what that is and change it.

edit flag offensive delete link more
0

answered 2013-11-28 00:35:17 -0500

Nazmil gravatar image

its running on ubuntu server 12.1 quantal.

based from the guide, im using rabbitmq since thats the package that i've installed.

i notice that in my /etc/cinder/cinder.conf

rootwrap_config=/etc/cinder/rootwrap.conf
sql_connection = mysql://cinderUser:cinderPass@16.189.82.181/cinder
api_paste_confg = /etc/cinder/api-paste.ini
iscsi_helper=ietadm
volume_name_template = volume-%s
volume_group = cinder-volumes
verbose = True
auth_strategy = keystone
rpc_backend = cinder.rpc.impl_kombu

the "rpc_backend = cinder.rpc.impl_kombu" is set. does it related to my backend error above?

if i commented that out, i would receive something as below once i run "cinder-manage db sync"

root@computenode:/home/openstack# cinder-manage db sync
2013-11-28 14:22:04 6692 DEBUG cinder.utils [-] backend <module 'cinder.db.sqlalchemy.migration' from '/usr/lib/python2.7/dist-packages/cinder/db/sqlalchemy/migration.pyc'> __get_backend /usr/lib/python2.7/dist-packages/cinder/utils.py:481
root@computenode:/home/openstack#

any ideas?

edit flag offensive delete link more

Comments

can you send me the complete cinder configuration file ? You can use pastebin.com or I can share my email id with you.

dheeru gravatar imagedheeru ( 2013-11-28 01:09:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-11-27 03:31:27 -0500

Seen: 1,602 times

Last updated: Nov 28 '13