Grizzly: Quantum type error [closed]

asked 2013-11-26 23:37:30 -0500

pragadeeswaran gravatar image

updated 2013-11-29 17:15:05 -0500

smaffulli gravatar image

I have picked up the latest packages of OpenStack -- Grizzly release. When starting the Quantum server...I see the below error in the server.log

2013-11-27 10:48:47    ERROR [quantum.openstack.common.rpc.amqp] Exception during message handling
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/quantum/openstack/common/rpc/amqp.py", line 430, in _process_data
    rval = self.proxy.dispatch(ctxt, version, method, **args)
  File "/usr/lib/python2.7/dist-packages/quantum/common/rpc.py", line 43, in dispatch
    quantum_ctxt, version, method, **kwargs)
  File "/usr/lib/python2.7/dist-packages/quantum/openstack/common/rpc/dispatcher.py", line 133, in dispatch
    return getattr(proxyobj, method)(ctxt, **kwargs)
  File "/usr/lib/python2.7/dist-packages/quantum/db/agents_db.py", line 173, in report_state
    plugin.create_or_update_agent(context, agent_state)
  File "/usr/lib/python2.7/dist-packages/quantum/db/agents_db.py", line 145, in create_or_update_agent
    context, agent['agent_type'], agent['host'])
  File "/usr/lib/python2.7/dist-packages/quantum/db/agents_db.py", line 121, in _get_agent_by_type_and_host
    Agent.host == host).one()
TypeError: <lambda>() takes exactly 2 arguments (3 given)

The backend is Postgres database with RabbitMQ running on a single node Ubuntu 12.04.03. The plan is to configure the system to use a single flat network.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2016-06-21 14:09:54.212251

Comments

The version of OpenStack that this is opened against has been declared EOL as per http://releases.openstack.org/ Please open a new issue if you are still seeing this problem with a more recent, supported version of OpenStack. Thanks.

rbowen gravatar imagerbowen ( 2016-06-21 14:09:48 -0500 )edit