Ask Your Question

packstack --allinone problems

asked 2013-11-26 14:20:42 -0500

eckman914 gravatar image

updated 2013-11-29 10:22:52 -0500

sgordon gravatar image

I'm trying to set up RDO on a Linux laptop for testing and evaluation purposes. I'm following the directions from the page. Everything seems to start off fine with loading the repositories using the yum command but when I try to setup OpenStack using the packstack --allinone command I get this request.

Setting up ssh keys...root@'s password:

What password is it asking for? My root password on the local system doesn't work. The ip-address is for my wlan0, which is my wireless lan. So I tried using the WEP password but that doesn't work either.

These are the last few lines of the stack.

File "/usr/lib/python2.6/site-packages/packstack/installer/", line 90, in runAllSequences
File "/usr/lib/python2.6/site-packages/packstack/installer/core/", line 105, in run
File "/usr/lib/python2.6/site-packages/packstack/installer/core/", line 46, in run self.function(config)
File "/usr/lib/python2.6/site-packages/packstack/plugins/", line 251, in install_keys server.execute()
File "/usr/lib/python2.6/site-packages/packstack/installer/utils/", line 89, in execute out, err = obj.communicate(script)

I would really like to find out what script is being run here.

Thanks, George

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted

answered 2013-11-29 09:48:39 -0500

marafa gravatar image

have you enabled PermitRootLogin in your sshd_config file?

edit flag offensive delete link more


Thanks! That was it!

eckman914 gravatar imageeckman914 ( 2013-12-06 10:00:45 -0500 )edit

answered 2013-11-26 14:30:23 -0500

iTone gravatar image

Hi, It's asking for the root account password for the Linux server you are installing openstack on. You set this when you installed Linux and used it to login the first time.

edit flag offensive delete link more


That is the password I am using, the root userid password. I can 'su root' using it just fine, but the prompt root@'s password: fails consistently when I enter it.

eckman914 gravatar imageeckman914 ( 2013-11-26 16:01:53 -0500 )edit

I think u will have to set the root password first.It is not set

anshul tripathi gravatar imageanshul tripathi ( 2013-11-26 21:08:34 -0500 )edit

I know the root password is set I can log onto my system as "root". I think there may be a problem with how my system is configured. packstack is trying to run a script that is asking for the root password.

eckman914 gravatar imageeckman914 ( 2013-11-27 09:31:06 -0500 )edit

answered 2013-12-06 10:01:47 -0500

eckman914 gravatar image

Marafa figured it out I needed to PermitRootLogin=yes in my sshd_config file

edit flag offensive delete link more



I already have set PermitRootLogin=yes in sshd_config file.. i still see packstack aio asking me for my root passwd toooo many times...

Installing: Clean Up [ DONE ] root@'s password: Setting up ssh keys [ DONE ] root@'s password: root@'s password:

... ... Adding Glance manifest entries [ DONE ] root@'s password: Installing dependencies for Cinder [ DONE ] Adding Cinder Keystone manifest entries [ DONE ] Adding Cinder manifest entries [ DONE ] root@'s password: root@'s password: Checking if the Cinder server has a cinder-volumes vg[ DONE ] .. .. Adding Nagios host manifest entries [ DONE ] Adding post install manifest entries [ DONE ] root@'s password: root@'s password: root@'s password: root@'s password:

... ... Copying Puppet modules and manifests ...(more)

deepakcs gravatar imagedeepakcs ( 2014-04-07 08:06:40 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2013-11-26 14:20:42 -0500

Seen: 1,447 times

Last updated: Dec 06 '13