Ask Your Question
0

Access was denied while creating network in Grizzly

asked 2013-05-06 04:01:10 -0600

anonymous user

Anonymous

updated 2013-05-06 17:37:24 -0600

smaffulli gravatar image

While creating a network in Grizzly version , i am getting following error : {"QuantumError": "Access was denied to this resource."}. I have tried creating network using both tenant i.e. admin or demo and sourced with novarc where admin is specified as a tenant.

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2013-05-08 07:49:40 -0600

amit dwivedi gravatar image

in quantum server.log the error is: ERROR [quantum.api.v2.resource] create failed Traceback (most recent call last): File "/usr/local/lib/python2.7/dist-packages/quantum-2012.2.3-py2.7.egg/quantum/api/v2/resource.py", line 96, etc ...

edit flag offensive delete link more
0

answered 2013-05-06 06:41:37 -0600

alexk gravatar image

Did you properly source your auth credentials?

edit flag offensive delete link more

Comments

I sourced with novarc and novarc contains following entry: export OSTENANTNAME=admin export OSUSERNAME=admin export OSPASSWORD=password export OSAUTHURL="http://localhost:5000/v2.0/" export SERVICEENDPOINT="http://localhost:35357/v2.0" export SERVICETOKEN=password export OSNOCACHE=1

amit dwivedi gravatar imageamit dwivedi ( 2013-05-06 08:19:14 -0600 )edit
0

answered 2013-05-07 10:31:04 -0600

armando-migliaccio gravatar image

There may be a few reasons why you are getting this error. I suggest you to run the command in verbose mode (i.e. with the --verbose switch) or check the Quantum Server log to understand a bit more.

Also, try the following command to be sure that keystone knows about your networking service:

keystone catalog --service network

edit flag offensive delete link more

Comments

while running the command keystone catalog --service network, i am getting following error:Configuration error: Client configured to run without a service catalog. Run the client using --os-auth-url or OSAUTHURL, instead of --os-endpoint or OSSERVICEENDPOINT, for example.

amit dwivedi gravatar imageamit dwivedi ( 2013-05-08 07:45:18 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-05-06 04:01:10 -0600

Seen: 420 times

Last updated: May 07 '13