Ask Your Question
0

PasteAppNotFound: Could not load paste app 'ec2' from /etc/nova/api-paste.ini

asked 2013-11-25 18:24:34 -0500

stacksam gravatar image

updated 2013-11-29 17:20:23 -0500

Hello,

Running stack.sh on RHEL 6.1 giving this error. Any idea what's wrong? Thanks

I'm using the devstack distribution. I see EC2 module included in the api-paste.ini

 nova]$ cd /opt/stack/nova && /usr/bin/nova-api
2013-11-25 14:25:03.116 DEBUG nova.wsgi [-] Loading app ec2 from /etc/nova/api-paste.ini from (pid=31389) load_app /opt/stack/nova/nova/wsgi.py:485
2013-11-25 14:25:03.126 ERROR nova.wsgi [-] URI scheme not known: 'call' (from egg, config)
2013-11-25 14:25:03.127 CRITICAL nova [-] Could not load paste app 'ec2' from /etc/nova/api-paste.ini
2013-11-25 14:25:03.127 TRACE nova Traceback (most recent call last):
2013-11-25 14:25:03.127 TRACE nova   File "/usr/bin/nova-api", line 10, in <module>
2013-11-25 14:25:03.127 TRACE nova     sys.exit(main())
2013-11-25 14:25:03.127 TRACE nova   File "/opt/stack/nova/nova/cmd/api.py", line 49, in main
2013-11-25 14:25:03.127 TRACE nova     max_url_len=16384)
2013-11-25 14:25:03.127 TRACE nova   File "/opt/stack/nova/nova/service.py", line 308, in __init__
2013-11-25 14:25:03.127 TRACE nova     self.app = self.loader.load_app(name)
2013-11-25 14:25:03.127 TRACE nova   File "/opt/stack/nova/nova/wsgi.py", line 489, in load_app
2013-11-25 14:25:03.127 TRACE nova     raise exception.PasteAppNotFound(name=name, path=self.config_path)
2013-11-25 14:25:03.127 TRACE nova PasteAppNotFound: Could not load paste app 'ec2' from /etc/nova/api-paste.ini
</module>
edit retag flag offensive close merge delete

Comments

what's in /etc/nova/api-paste.ini ? How did you install OpenStack? What version of OpenStack are you running?

fifieldt gravatar imagefifieldt ( 2013-11-25 19:12:31 -0500 )edit

2 answers

Sort by » oldest newest most voted
0

answered 2013-11-25 19:56:56 -0500

stacksam gravatar image

I'm using the devstack distribution. I see EC2 module included in the api-paste.ini

edit flag offensive delete link more

Comments

Any idea what's wrong here?

stacksam gravatar imagestacksam ( 2013-11-27 11:23:21 -0500 )edit

Did you ever get this straightened out? I am doing an install (non DevStack) and have the same issue. Never had it before.

OldParrothead gravatar imageOldParrothead ( 2014-01-02 13:24:54 -0500 )edit
0

answered 2016-04-18 07:11:55 -0500

gokhan.isik gravatar image

Hi, I am getting same error on ubuntu 14.04 server. By branch is mitaka.I can't solve it. İs there any one who solved this error ?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-11-25 18:24:34 -0500

Seen: 1,114 times

Last updated: Apr 18 '16