Ask Your Question
0

publicURL endpoint for orchestration not found [closed]

asked 2013-11-25 13:37:35 -0500

antonnoble gravatar image

updated 2013-11-26 09:02:30 -0500

I have:

# keystone service-list
+----------------------------------+----------+----------------+---------------------------+
|                id                |   name   |      type      |        description        |
+----------------------------------+----------+----------------+---------------------------+
| f7c043e5b305456384d6002a191e7aed |  glance  |     image      |    Glance Image Service   |
| f223e1e6309c42d189f6f512ccd72cd5 |   heat   | Orchestration  |   Heat Orchestration API  |
| c81aede2173e4e71b82618e04d351331 | heat-cfn | cloudformation |  Heat CloudFormation API  |
| 1e9dc6ce38404fb290a2e6d75c6b4b9d | keystone |    identity    | Keystone Identity Service |
| 3a44e89c99d54af18d8741e6e1e2c652 |   nova   |    compute     |    Nova Compute Service   |
+----------------------------------+----------+----------------+---------------------------+

But:

# heat stack-list
publicURL endpoint for orchestration not found.

This is defined in my /etc/heat/heat.conf

[keystone_authoken]
auth_host = MYCONTROLLER
auth_port = 35357
auth_protocol = http
auth_uri = http://MYCONTROLLER:5000/v2.0
admin_tenant_name =service
admin_user = heat
admin_password = MYPASSWORD

[ec2authtoken]
auth_uri = http://MYCONTROLLER:5000/v2.0
keystone_ec2_uri = http://MYCONRTOLLER:5000/v2.0/ec2tokens

I followed the standard procedures for setting up Orchestration from the Havana install guide for Ubuntu 12.04. I get a Orchestration-stacks area under projects in Horizon but when I click on stack it errors out bringing up a something went wrong page.

Any direction on how to remedy this would be great. Thanks.

Based on comments and suggestions here is what my endpoints/services look like

I ran the --debug option on endpoint-list and service-list, but I'm not exactly sure what I am looking for? Also, I'm not sure how you want me to use the --os-region-name=regionOne or RegionOne in the syntax?

How can I send you the result of the debug?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by dheeru
close date 2013-11-26 20:57:53.230457

Comments

Does `keystone endpoint-list` show an endpoint for heat? Or `keystone endpoint-get --service orchestration`?

larsks gravatar imagelarsks ( 2013-11-25 15:16:07 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-11-25 16:28:46 -0500

asalkeld gravatar image

updated 2013-11-25 20:36:19 -0500

Your endpoint type is wrong.

f223e1e6309c42d189f6f512ccd72cd5 | heat | Orchestration | Heat Orchestration API |

this ^ is wrong, it should be (lower case):

f223e1e6309c42d189f6f512ccd72cd5 | heat | orchestration | Heat Orchestration API |

edit flag offensive delete link more

Comments

1

You were correct, I deleted the endpoint and service and recreated with orchestration and that solved that problem. However, now I'm getting an Invalid Openstack Identity credentials.... As you can see by my orignal post I have specified those in my heat.conf file, but it's just not working....

antonnoble gravatar imageantonnoble ( 2013-11-26 09:30:07 -0500 )edit
0

answered 2013-11-25 20:28:39 -0500

dheeru gravatar image

updated 2013-11-25 20:29:35 -0500

I think you must be having region issue. 
1. keystone 'endpoint-list' and 'keystone service-list'. Capture the output.
2. Run the command with --debug option. You will see parameters passed to you command.
3. --os-region-name=regionOne or RegionOne. Run the command.

If still does not work, send me output of all the above commands and the logs. I will look in to them.
edit flag offensive delete link more

Comments

Can you explain how I use the syntax for --os-region-name=regionOne? Example? keystone --os-region-name=regionOne service-list endpoint-list ??

antonnoble gravatar imageantonnoble ( 2013-11-26 09:04:16 -0500 )edit

yes --os-region-name=regionOne OR --os-region-name=RegionOne and --debug.

dheeru gravatar imagedheeru ( 2013-11-26 09:43:28 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-11-25 13:37:35 -0500

Seen: 6,686 times

Last updated: Nov 26 '13