Ask Your Question
2

Images or Snapshot images are not visible (is_public=false) [closed]

asked 2013-11-25 07:44:04 -0500

dheeru gravatar image
Havana + Ubuntu

Case#1
1.  I created 3 images using glance. 
2.  When i execute 'glance image-list' or 'nova image-list',  images were listed.

Case#2 - After 2-3 days
1. Created/added few more images through glance. 
2. Created snapshot images from horizon dashboard.
3. Newly created images are not visible when i execute 'glance image-list' or 'nova image-list'. It displays only the images created earlier(case#1).

I looked at the glance db 'images' table. is_public was set to false for newly created images. I used 'glance image-update' command and set the is_public=true. Images started showing. Updating the db directly also works.

Questions :
1. Is there any global flag such that images created are always visible. i.e is_public = true.
2. Why the snapshot images are always created with is_public = false.
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by dheeru
close date 2013-11-27 02:54:17.711424

2 answers

Sort by ยป oldest newest most voted
2

answered 2013-11-26 04:21:56 -0500

updated 2013-11-27 02:26:41 -0500

There's no global parameter that would make all images public. You have to create the image and then update it. You can update images through the CLI and/or the dashboard.

However, Glance client allows you to create public and private images. The default value is 'private', though. Some examples below.

(openstack)phantom ~ $ glance image-create --is-public True --name test                                                                                                                                             
+------------------+--------------------------------------+
| Property         | Value                                |
+------------------+--------------------------------------+
| checksum         | None                                 |
| container_format | None                                 |
| created_at       | 2013-11-26T09:17:00                  |
| deleted          | False                                |
| deleted_at       | None                                 |
| disk_format      | None                                 |
| id               | 08c19538-c003-47d6-843f-80c1407afc79 |
| is_public        | True                                 |
| min_disk         | 0                                    |
| min_ram          | 0                                    |
| name             | test                                 |
| owner            | c15e15442ddb4387a8c0f0ca2f46a1be     |
| protected        | False                                |
| size             | 0                                    |
| status           | queued                               |
| updated_at       | 2013-11-26T09:17:00                  |
+------------------+--------------------------------------+
(openstack)phantom ~ $ glance image-create --is-public False --name test2                                                                                                                                           
+------------------+--------------------------------------+
| Property         | Value                                |
+------------------+--------------------------------------+
| checksum         | None                                 |
| container_format | None                                 |
| created_at       | 2013-11-26T09:17:09                  |
| deleted          | False                                |
| deleted_at       | None                                 |
| disk_format      | None                                 |
| id               | 1d97a170-7b6b-4ee3-a7ed-6d47fca48c08 |
| is_public        | False                                |
| min_disk         | 0                                    |
| min_ram          | 0                                    |
| name             | test2                                |
| owner            | c15e15442ddb4387a8c0f0ca2f46a1be     |
| protected        | False                                |
| size             | 0                                    |
| status           | queued                               |
| updated_at       | 2013-11-26T09:17:09                  |
+------------------+--------------------------------------+
(openstack)phantom ~ $ glance image-create --name test3                                                                                                                                                             
+------------------+--------------------------------------+
| Property         | Value                                |
+------------------+--------------------------------------+
| checksum         | None                                 |
| container_format | None                                 |
| created_at       | 2013-11-26T09:17:29                  |
| deleted          | False                                |
| deleted_at       | None                                 |
| disk_format      | None                                 |
| id               | 4be89626-3332-4d2d-bdb8-1fefd9dcdfb0 |
| is_public        | False                                |
| min_disk         | 0                                    |
| min_ram          | 0                                    |
| name             | test3                                |
| owner            | c15e15442ddb4387a8c0f0ca2f46a1be     |
| protected        | False                                |
| size             | 0                                    |
| status           | queued                               |
| updated_at       | 2013-11-26T09:17:29                  |
+------------------+--------------------------------------+
edit flag offensive delete link more

Comments

Thanks for your time. You are right as you said here. I'm looking for any global flag which I can set in some configuration file so that it always created the public image.

dheeru gravatar imagedheeru ( 2013-11-27 00:20:21 -0500 )edit

This behavior evident. I too did not find any global parameter for the same. Thank you for your time.

dheeru gravatar imagedheeru ( 2013-11-27 02:54:03 -0500 )edit
0

answered 2013-11-26 02:40:52 -0500

sngirame gravatar image
  1. AFAIK, glance image-create does not have any option to create 'public' image. Although same can be done using dashboard.

  2. May be for security reason default setting of is_public = false.

edit flag offensive delete link more

Comments

Thank you for your response. I appreciate your time. Some times it has created public and sometimes private. Also from dashboard it always creates private. If security reason, it should always create private, but that is not the case. In grizzly from dashboard it was always creating public.

dheeru gravatar imagedheeru ( 2013-11-26 03:43:19 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-11-25 07:44:04 -0500

Seen: 3,031 times

Last updated: Nov 27 '13