Ask Your Question
0

Why isn't OpenStack Swift sending metrics to Statsd server? [closed]

asked 2013-05-03 14:32:59 -0500

anonymous user

Anonymous

updated 2013-05-03 18:38:51 -0500

smaffulli gravatar image

Hello,

I'm setting up OpenStack Swift for the first time following the OpenStack Object Storage Administration Manual trunk (Dec 6, 2012). I have the base system working, but am having trouble getting swift to send metrics to a statsd server.

I'm running Ubuntu 12.04.2 with swift installed via the latest repo.

Here is the proxy-server.conf from one of the swift servers.

[DEFAULT]
# Enter these next two values if using SSL certifications
cert_file = /etc/swift/cert.crt
key_file = /etc/swift/cert.key
bind_port = 443
log_statsd_host = REMOVED
log_statsd_port = 8125
log_statsd_default_sample_rate = 1.0
log_statsd_sample_rate_factor = 1.0
log_statsd_metric_prefix = bb2

[pipeline:main]
# keep swauth in the line below if you plan to use swauth for authentication
pipeline = catch_errors healthcheck swauth proxy-server

[app:proxy-server]
use = egg:swift#proxy
allow_account_management = true

[filter:swauth]
# the line below points to swauth as a separate project from swift
use = egg:swauth#swauth
# Highly recommended to change this.
super_admin_key = REMOVED
default_swift_cluster = bb#https://REMOVED:443/v1#https://127.0.0.1:443/v1

[filter:healthcheck]
use = egg:swift#healthcheck

[filter:cache]
use = egg:swift#memcache
memcache_servers = REMOVED:11211,REMOVED:11211,REMOVED:11211

[filter:catch_errors]
use = egg:swift#catch_errors

I ran tcpdump on the swift server and there doesn't seem to be any traffic on port 8125.

Any ideas?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by koolhead17
close date 2013-12-26 02:56:47.039020

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-05-04 11:49:06 -0500

torgomatic gravatar image

updated 2013-05-04 16:16:45 -0500

The proxy logging code only supports having log_statsd_host set to an IPv4 address. Since you've redacted the value of log_statsd_host from the posted config file, I can't tell if that's the problem or not, but it's worth checking.

Also, StatsD support was added in Swift 1.5.0, which IIRC is newer than what's packaged with Ubuntu 12.04. If you're running 1.4.8, you'll need to upgrade.

edit flag offensive delete link more

Comments

The addresses are IPv4, but that's good to know.

I re-installed with Swift 1.8.0 on Ubuntu server 13.04 and it's working now. Thank you for your help

comrade gravatar imagecomrade ( 2013-05-08 13:20:36 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-05-03 14:32:59 -0500

Seen: 407 times

Last updated: May 07 '13