Ask Your Question
0

br-ex/eth0 mapping isn't saved

asked 2013-11-22 20:08:32 -0500

kbreit gravatar image

updated 2013-11-22 20:09:38 -0500

I manually set the br-ex and eth0 binding on my RDO setup and that enables the networking to work fine. When I restart the networking process in the OS though, it doesn't keep this binding and I lose connectivity to my host. Is there a reason this is the case? What can I do to help fix the problem?

After some work, I've realized CentOS has OVS initiate on boot before eth0. Would this make a difference?

This post came from http://openstack.redhat.com/forum/discussion/927/br-exeth0-mapping-isnt-saved

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
3

answered 2013-11-23 00:29:05 -0500

I have the following in interfaces and it works:

/etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=eth0
NM_CONTROLLED="yes"
ONBOOT="yes"
IPV6INIT=no
TYPE="OVSPort"
DEVICETYPE="ovs"
OVS_BRIDGE=br-ex

/etc/sysconfig/network-scripts/ifcfg-br-ex

DEVICE="br-ex"
BOOTPROTO="none"
DNS1="8.8.8.8"
GATEWAY=192.168.250.1
IPADDR=192.168.250.20
NETMASK=255.255.254.0
ONBOOT="yes"
TYPE="OVSBridge"
DEVICETYPE="ovs"
edit flag offensive delete link more

Comments

This solved my problem. #RDO team...should the scripts reconfigure these interfaces properly? eth0 was setup as Ethernet, not OVSBridge.

kbreit gravatar imagekbreit ( 2013-11-23 09:10:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2013-11-22 20:08:32 -0500

Seen: 340 times

Last updated: Nov 23 '13