Instance not connecting through NComputing [closed]

asked 2013-11-22 03:10:12 -0500

Anand TS gravatar image

updated 2014-12-16 19:42:15 -0500

fifieldt gravatar image

Hi All,

I have setup openstack using packstack grizzly all in one installation in CentOS6.4. Launched 3 windows 2003 servers and all were working fine.

I tried to take snapshot of a running instance and it got successful. But the problem arised after that. Users loggin to that server cannot access the machine through Ncomputing device but for other 2 servers they can take through nComputing . But I am able to take remote desktop for the same machine. I checked the network configuration and every thing was fine.

I recreated an instance from the snapshot and tried to gave the same/diff floating IP. Still no luck. When I restarted the host itself users can take instance through NComputing device. But after sometime instances getting restarted and once it is down, it is not possible to take it back via ncomputing.

Also when check the nova services, all the services was up except nova-compute. I run debug command /usr/bin/nova-compute --config-file /etc/nova/nova.conf , it got up. but when I check the status it says nova-compute is dead but pid file exists. It is quite often nova-compute service is going down.

openstack-status

== Nova services == openstack-nova-api: active
openstack-nova-cert: active
openstack-nova-compute: dead
openstack-nova-network: active
openstack-nova-scheduler: active
openstack-nova-volume: dead (disabled on boot)
openstack-nova-conductor: active

but in ,nova-manage service list it shows.

Binary Host Zone Status State Updated_At nova-scheduler bfsiopenstack internal enabled :-) 2013-11-22 06:51:12
nova-cert bfsiopenstack internal enabled :-) 2013-11-22 06:51:12
nova-conductor bfsiopenstack internal enabled :-) 2013-11-22 06:51:12
nova-network bfsiopenstack internal enabled :-) 2013-11-22 06:51:17
nova-compute bfsiopenstack nova enabled :-) 2013-11-22 06:51:17
nova-consoleauth bfsiopenstack internal enabled :-) 2013-11-22 06:51:12
nova-console bfsiopenstack internal enabled :-) 2013-11-22 06:51:12

I tried to delete the pid file from /var/run/nova/compute.pid and restart the nova-compute service. Still it shows dead but pid file exists.

If you guys have any idea of what is happening to my setup. pls pls revert.

Thanks in advance, Anand

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2016-09-27 11:19:20.768932

Comments

Closing: This question relates to a version of OpenStack which has been marked End Of Life. If you are still experiencing this problem with a more recent version of OpenStack, please open a new question with updated details. Thanks!

rbowen gravatar imagerbowen ( 2016-09-27 11:19:16 -0500 )edit